You are viewing the PKP Support Forum | PKP Home Wiki

new to OJS - international journal editorial team

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

new to OJS - international journal editorial team

Postby andrecolbert » Mon Jun 04, 2012 1:28 am


We are a non-profit academic society that has recently installed OJS for an international journal that we have taken over. We have registered quite a few Editors, Reviewers and Authors in the system. They have now begun testing the and accepting submissions from authors. However, a number of them have reported problems that I have compiled into a list below. Some of these issues may be user created and others may be configuration related or just plain bugs. Perhaps several of these issues have one cause? I don't have access to the server side set-up so I can't even see what's going on. They did send me a copy of the config file but I don't want to ask them to change any settings until I get some advice from this forum (hopefully).

If anyone can shed some light on any of these issues, it would be great.

I am a Journal Manager. OJS was installed on a hosting company server that offers us free support. All I know about the hosting environment at this stage is that it is a Linux server and therefore we are using PHPMail and not Exchange. Perhaps I should ask them to activate scheduled_tasks=On in the config file and disable mod_rewrite because I saw a post where that interfered with emails?? Other than that, I don't know if there are any other config files that would help. i have asked them if they've installed all the patch files but I haven't heard back yet.


The login return URL page is blank after clicking the "login" button. You must click the browser back button to display the logged-in page. This is the same situation if you update any settings as the Journal Manager. I have checked this in several browsers and it is the same result.


1. Emails sent to authors are not saved even when you do not assign yourself as the editor to record the decision.
2. Reject emails are not saved or sent.
3. Email Overwritten: an email sent to an author (Editor’s Decision section) with the reviewers’ comments is overwritten by the authors’ reply.
4. Email not sent: manual email sent to reviewer [to allocate papers] are not sent.
5. Email Error message occurs when you send an email from the review menu for a revised document. At a later point, the email shows-up.
6. Late/overdue email reminder does not get generated.


1. Uploaded submission receipts are not issued to the submitter to let them know that they have been successful in uploading a document.
2. Review file checkbox doesn’t show-up at the bottom of the page.
3. Rejected articles remain in the system archives even though no Editor decision is recorded via the 'Reject and archive' option.
Posts: 3
Joined: Wed May 23, 2012 6:09 am

Return to OJS Technical Support

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest