OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Strange behaviour in issues' subscription set up

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Strange behaviour in issues' subscription set up

Postby marchitelli » Wed May 30, 2012 2:11 pm

Hi,
I'm trying to set up a subscription based journal, with delayed OA (OJS 2.3.3-3).

I set up in 4.1
The journal will require subscriptions to access some or all of its contents.
and
Always show galley links and indicate restricted access.


I have a subscription manager, subscription type and policies but I can not get the oa/submission option in issue data, as an editor. I only get this option AFTER I've published an issue, but never before to publish.

In a test journal, on the same issue, I can set up subscription issues before publishing, too, and I can not see any differences in the journals' setup.

What can cause this strange behaviour?

Best,
andrea
marchitelli
 
Posts: 120
Joined: Tue May 22, 2007 12:44 am

Re: Strange behaviour in issues' subscription set up

Postby marchitelli » Sun Jun 03, 2012 3:39 am

I think that I found the problem, but I can not solve on myself.

The journal is offering delayed open access; whein in /manager/subscriptionPolicies the box related to
The back issues of this journal will be available in an open access format month(s) after an issue is published.

is flagged I can't get the box to set the Access status in /editor/createIssue before the issue publication.

When the issue is published, I can see the Access status box and I can set the issue/articles accessibility conditions; butI think that is important for editors to set up resrtricted accessibility before the issue is published.

Andrea
marchitelli
 
Posts: 120
Joined: Tue May 22, 2007 12:44 am

Re: Strange behaviour in issues' subscription set up

Postby michael » Wed Jun 06, 2012 11:21 pm

Hi Andrea,

Thanks for the additional info and tracking this down.

I've filed this as a bug here and will have a fix for you shortly.

Cheers,
Michael
michael
 
Posts: 405
Joined: Thu Mar 29, 2007 2:09 pm

Re: Strange behaviour in issues' subscription set up

Postby michael » Mon Aug 06, 2012 1:54 pm

Hi Andrea,

Can you please try the patch attached to the above bug report and see if that fixes the issue for you?

Thanks,
Michael
michael
 
Posts: 405
Joined: Thu Mar 29, 2007 2:09 pm

Re: Strange behaviour in issues' subscription set up

Postby marchitelli » Tue Aug 07, 2012 2:46 am

Hi Michael,
we have installed and tested your patch: it works perfectly now!

Thanks,
Andrea
marchitelli
 
Posts: 120
Joined: Tue May 22, 2007 12:44 am


Return to OJS Technical Support

Who is online

Users browsing this forum: mbria and 5 guests