OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Email messages not sending

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Email messages not sending

Postby katielegere » Mon Apr 30, 2012 10:17 am

We have an existing OJS installation that has been working perfectly for some time. Recently it appears to have stopped sending emails though. The cron jobs are running but, for instance, if I sign up as a new user, I don't get an email response. We haven't changed any of the code in the config file and, as I said, it was working correctly until late February. The web server that this is sitting on is sending mail.

Doe anyone have any ideas what else could be wrong?
katielegere
 
Posts: 11
Joined: Wed Mar 28, 2012 7:52 am

Re: Email messages not sending

Postby JasonNugent » Tue May 01, 2012 10:37 am

Hi katie,

Anything showing up in your mail server logs? You may also want to check the mail spool file for the user that your web server runs as. If mail is bouncing back for some reason, they often end up in there, along with a reason.

Regards,
Jason
JasonNugent
Site Admin
 
Posts: 877
Joined: Tue Jan 10, 2006 6:20 am

Re: Email messages not sending

Postby katielegere » Mon May 07, 2012 11:29 am

I will ask that... in the meantime I've posted here as this actually seems like the issue : viewtopic.php?f=8&t=8448&p=33480#p33480
katielegere
 
Posts: 11
Joined: Wed Mar 28, 2012 7:52 am

Re: Email messages not sending

Postby JasonNugent » Mon May 07, 2012 4:24 pm

Hi Katie,

In response to your other thread, I tested my own OJS 2.3.7 installation here, and went to Journal Manager -> Roles and successfully sent myself an email.

If it works for your sendmail test and not for OJS, you may want to examine the differences between the two sets of config files. It is also quite useful to monitor your mail log file in a shell window when you click 'send' to see what happens. When I debug these things I will use

Code: Select all
tail -f /var/log/maillog


(or whatever your mail log might be). When I submit the OJS form I immediately see whether or not the mail message is going to go out. If it bounces back, I'll see the reason right there, too.

Regards,
Jason
JasonNugent
Site Admin
 
Posts: 877
Joined: Tue Jan 10, 2006 6:20 am

Re: Email messages not sending

Postby katielegere » Tue May 08, 2012 12:09 pm

When the email fails we are getting an assertion error .... does this ring a bell for anyone?

Mon May 07 13:52:38 2012] [error] [client 130.15.161.72] ojs2 has produced an error\n Message: WARNING: assert() [<a href='function.assert'>function.assert</a>]: Assertion failed\n In file: /home/lojswww/www/lib/pkp/classes/db/DAO.inc.php\n At line: 446\n Stacktrace: \n Server info:\n OS: SunOS\n PHP Version: 5.2.9\n Apache Version: Apache\n DB Driver: mysql\n DB server version: 5. 1.30-log, referer: http://library.queensu.ca/ojs/index.php ... ople%2Fall
katielegere
 
Posts: 11
Joined: Wed Mar 28, 2012 7:52 am


Return to OJS Technical Support

Who is online

Users browsing this forum: Yahoo [Bot] and 5 guests