OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



failed to send emails

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

failed to send emails

Postby lixh » Wed Mar 21, 2012 6:50 pm

Dear Sir,

We use OJS as our peer review system and email server we used is Google Apps, we use this since 2010, but recently we found sometimes the system failed to sent emails.

In fact, we clicking send and then found the email is lost, it is not in the email log also the receiver will not got it.

I am not sure what's the problem, would highly appreciate if you could help us!

Regards,
Xianghua
RAA Editorial Office
lixh
 
Posts: 39
Joined: Fri Nov 28, 2008 1:03 am

Re: failed to send emails

Postby Thomaswedge » Thu Mar 22, 2012 10:51 am

I am also having the same problem, didn't think I should make a new thread. Hopefully someone can help.
beezid review
Last edited by Thomaswedge on Sat Mar 31, 2012 4:37 pm, edited 1 time in total.
Thomaswedge
 
Posts: 1
Joined: Thu Mar 22, 2012 10:35 am

Re: failed to send emails

Postby jmacgreg » Fri Mar 23, 2012 4:16 pm

Hi folks,

A few things to check:

-- check and see if any emails at all are getting out; try sending one to yourself through the system by looking yourself up in the Journal Management -> Roles pages (you'll find an email icon next to your name).

-- check with the email service provider, in this case Google Apps, to see if anything has changed configuration-wise, or to see if they are experiencing problems on their end.

-- double-check the email logs on the system, especially the submission history email logs, to see if there is a record of these emails going out. If not, please let us know exactly which email this is.

-- Let us know which version of OJS you are using, whether you have recently upgraded and/or whether the server software (eg. Apache; PHP) was recently upgraded.

If both of you are only recently having problems, and are both using Google Apps as the mail server, I suspect that the problem is with Google Apps -- you should be able to follow up with them to see if anything has changed wrt their software offerings.

Cheers,
James
jmacgreg
 
Posts: 4190
Joined: Tue Feb 14, 2006 10:50 am

Re: failed to send emails

Postby katielegere » Mon May 07, 2012 10:59 am

I am having a similar problem.
--- I sent a test email to myself through the system by looking me up in the Journal Management -> Roles pages - no email was sent
--- I wrote a simple php sendmail page and put it in the root folder of the directory - it sent mail perfectly
-- double-check the email logs on the system, especially the submission history email logs, to see if there is a record of these emails going out - I am very new to this ... where are these logs?
--- We are still using OJS- 2.3.6.0 and as far as I know we have not upgraded anything recently.
katielegere
 
Posts: 11
Joined: Wed Mar 28, 2012 7:52 am

Re: failed to send emails

Postby katielegere » Mon May 28, 2012 6:35 am

When the email fails we are getting an assertion error .... does this ring a bell for anyone?

Mon May 07 13:52:38 2012] [error] [client 130.15.161.72] ojs2 has produced an error\n Message: WARNING: assert() [<a href='function.assert'>function.assert</a>]: Assertion failed\n In file: /home/lojswww/www/lib/pkp/classes/db/DAO.inc.php\n At line: 446\n Stacktrace: \n Server info:\n OS: SunOS\n PHP Version: 5.2.9\n Apache Version: Apache\n DB Driver: mysql\n DB server version: 5. 1.30-log, referer: http://library.queensu.ca/ojs/index.php ... ople%2Fall
katielegere
 
Posts: 11
Joined: Wed Mar 28, 2012 7:52 am


Return to OJS Technical Support

Who is online

Users browsing this forum: Bing [Bot], Google [Bot], Yahoo [Bot] and 10 guests