You are viewing the PKP Support Forum | PKP Home Wiki

Language attribute forgot in Native import/export pluguin?

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

Language attribute forgot in Native import/export pluguin?

Postby Marc » Wed Mar 08, 2006 12:47 pm

Hi folks,

I’m using the native importexport pluguin and I’ve had troubles importing the attribute « language » of an article.

Seeking in the code, I’ve found the attribute « language » is used for a supplementary file, but it doesn’t for an article.

I’ve found anything in the CVS about some change concerning this issue.

Finally, I’ve added the next patch (in ./ojs-2.0.2-1/plugins/importexport/native/NativeImportDom.inc.php) and that works for me:

if($lang = $articleNode->getAttribute('language')) $article->setLanguage($lang);

What do you think about that?


Posts: 34
Joined: Thu Jul 07, 2005 5:16 am
Location: Barcelona

Postby asmecher » Wed Mar 08, 2006 1:51 pm

Thanks, Marc -- this will be included in the next incremental release. For the bugzilla entry and a link to a patch, go to http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=2100.

Alec Smecher
Open Journal Systems Team
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Return to OJS Technical Support

Who is online

Users browsing this forum: Yahoo [Bot] and 3 guests