OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Odd behaviors after 2.1.0-1 upgrade

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Odd behaviors after 2.1.0-1 upgrade

Postby sjones » Sun Feb 12, 2006 2:57 pm

I've encountered two rather odd things since upgrading to 2.1.0-1 and I can't figure out why they're happening or how to stop them from happening.

1. When logged in as section editor, on the navigation menu at the top of the page when viewing a manuscript, instead of reading as it had prior to the upgrade:

Home > User Home > Section Editor Submissions > #2 > Review

the page reads:

Home > ##navigation.usear## > Section Editor Submissions > #2 > Review

I can't figure out where the "##navigation.usear##" is coming from or how to make it stop. It doesn't seem to affect operation.

2. Again as section editor, when on the page listing all submissions currently under review, the "Review Due" column no longer lists the whole date, just a single number.

I have screen shots of these if that would be of any use, too.

Thanks in advance for any help!

Sj
sjones
 
Posts: 46
Joined: Sun Jan 29, 2006 8:47 am

Postby asmecher » Sun Feb 12, 2006 8:08 pm

Hi Sjones,

Your first item is indeed a bug, but just a typo. See http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=2072 for information on the bug and a patch to correct it. If you're not familiar with the process of applying a patch, follow these steps to correct it by hand:
  • Edit pages/sectionEditor/SectionEditorHandler.inc.php
  • Go to line 145:
    Code: Select all
    $pageHierarchy = $subclass ? array(array(Request::url(null, 'user'), 'navigation.usear'), array(Request::url(null, $isEditor?'editor':'sectionEditor'), $isEditor?'user.role.editor':'user.role.sectionEditor'), array(Request::url(null, $isEditor?'editor':'sectionEditor'), 'article.submissions'))
  • Change navigation.usear to navigation.user and the problem will be corrected.
For the second item you mention, the "due date" display has been changed to a number of weeks rather than an actual date. If you'd rather display the actual due date, edit templates/sectionEditor/submissionsInReview.tpl and templates/editor/submissionsInReview.tpl and change (around line 53):
Code: Select all
{$assignment->getWeeksDue()}
to
Code: Select all
{$assignment->getDateDue()|date_format:$dateFormatTrunc}
Regards,
Alec Smecher
Open Journal Systems Team
Last edited by asmecher on Wed Dec 13, 2006 12:23 pm, edited 1 time in total.
asmecher
 
Posts: 8316
Joined: Wed Aug 10, 2005 12:56 pm

Postby sjones » Wed Feb 15, 2006 2:19 pm

Fantastic - thank you! Easily edited, both of them, thanks for the clear instructions.

Sj
sjones
 
Posts: 46
Joined: Sun Jan 29, 2006 8:47 am


Return to OJS Technical Support

Who is online

Users browsing this forum: Google [Bot] and 3 guests