OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Editing an article after an upgrade from ojs223 to ojs233

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Editing an article after an upgrade from ojs223 to ojs233

Postby acuartango » Tue Feb 01, 2011 6:58 am

Hello,
we have done a unpgrade from ojs223 to ojs233, then we've try to publish some articles in edition phase to a new number of the journal. But in the editing page we can see only:
---------------------------------
Submission
Authors XXXXXXXXXXXX
Title XXXXXXX
Section ARTICLES
Editor XXXXXXXXX
(Editor) Theoria
Copyediting
REVIEW METADATA REQUEST UNDERWAY COMPLETE ACKNOWLEDGE
1. Initial Copyedit 2011-01-22 N/A 2011-01-22 N/A
File: 609-1747-2-ED.PDF 2010-09-02

2. Author Copyedit
-----------------------------------

But dont show anyting else 3 4 5 ... doesn't appears. With new articles this goes well, but with existings before upgrading not, and users want to have the article history (aprovations, comments etc)

Thank you so much, and sorry because my poor english.
Aitor Cuartango
UPV/EHU University
acuartango
 
Posts: 12
Joined: Mon Jan 17, 2011 12:41 am

Re: Editing an article after an upgrade from ojs223 to ojs233

Postby Edwin.chain » Mon Feb 14, 2011 8:45 am

I had the same problem too when I upgraded to OJS 2.3.4. Maybe I can resolve your problem If you tell me the php error report on this page. mail me(edwin.chain 'at' gmail.com)
Edwin.chain
 
Posts: 3
Joined: Thu Nov 01, 2007 2:43 am
Location: China

Re: Editing an article after an upgrade from ojs223 to ojs233

Postby acuartango » Mon Feb 21, 2011 2:22 am

Hello Edwing, the first is thanks your help.

The second is that there is no PHP error or nothing in the page. The error is that i don't see all the page in "editing" in some articles (not all). These articles i think that were not well actualized in the migration, but is only one idea, i don't know what's happens.

If any of you have got any idea or something will be welcome!

thank you,
aitor UPV/EHU University of the Basque Country
acuartango
 
Posts: 12
Joined: Mon Jan 17, 2011 12:41 am

Re: Editing an article after an upgrade from ojs223 to ojs233

Postby acuartango » Mon Feb 21, 2011 8:27 am

If I've activated in php.ini the "display_error", and i see:

2. Author Copyedit
Fatal error: Call to a member function getDateNotified() on a non-object in ./cache/t_compile/%%B0^B03^B0335942%%copyedit.tpl.php on line 151
acuartango
 
Posts: 12
Joined: Mon Jan 17, 2011 12:41 am

Re: Editing an article after an upgrade from ojs223 to ojs233

Postby acuartango » Mon Feb 21, 2011 8:39 am

Edwin Chain has send me a path. With the patch the aplication goes well. Tomorrow i'll ask to Edwin to link to the patch from here.

Thanks to all, Spetially to Edwin

aitor
UPV/EHU Unibersity of the Basque Country
acuartango
 
Posts: 12
Joined: Mon Jan 17, 2011 12:41 am

Re: Editing an article after an upgrade from ojs223 to ojs233

Postby Edwin.chain » Tue Feb 22, 2011 7:28 pm

Hi,Aitor

You are welcome!

If others have the same problem, you could try the following method:
The problem should be fixed If you copy this file(in attachment) and overwrite the same file in \lib\pkp\classes\signoff\SignoffDAO.inc.php
SignoffDAO.inc.rar
SignoffDAO
(2.17 KiB) Downloaded 53 times


I can't make sure that it is a good patch for this bug, please let the PKP developer to review it.
Edwin.chain
 
Posts: 3
Joined: Thu Nov 01, 2007 2:43 am
Location: China

Re: Editing an article after an upgrade from ojs223 to ojs233

Postby hekutoru2kx » Thu Feb 24, 2011 3:37 pm

Thank You very much for your solution. It might be a temporary one, but it works ;)... We are having the same problem (viewtopic.php?f=8&t=7054) and we are waiting for developers answer. Until then, I think i'll use your patch.
hekutoru2kx
 
Posts: 71
Joined: Wed Jul 28, 2010 12:47 pm

Re: Editing an article after an upgrade from ojs223 to ojs233

Postby jmacgreg » Sun Feb 27, 2011 6:08 pm

Hi all,

Thanks, Edwin, for posting a patch, and thanks hekutoru2kx for providing a link to the other forum thread. We'll be getting an official fix posted online soon.

Cheers,
James
jmacgreg
 
Posts: 4190
Joined: Tue Feb 14, 2006 10:50 am

Re: Editing an article after an upgrade from ojs223 to ojs233

Postby jbutler1 » Fri Mar 18, 2011 7:23 am

Hi OJS Team,
I'm experiencing the same problem as the others above after my upgrade. I tried swapping out the SignoffDAO file, it fixes the issue with viewing the rest of the editing page. But now I can’t push the file from Review into Copyediting or upload a new file into Copyediting. This functionality worked fine before the SingoffDAO swap. Any word on when an official fix will be out.
Thanks,
- Jim
jbutler1
 
Posts: 13
Joined: Thu Oct 11, 2007 10:23 am

Re: Editing an article after an upgrade from ojs223 to ojs233

Postby asmecher » Fri Mar 18, 2011 8:30 am

Hi all,

A fix for this has already been posted on our Recommended Patches list; see the list at http://pkp.sfu.ca/wiki/index.php/OJS_2.3.4_Recommended_Patches and go to http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=6456 for the bug entry including patch.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8673
Joined: Wed Aug 10, 2005 12:56 pm

Re: Editing an article after an upgrade from ojs223 to ojs233

Postby jbutler1 » Tue Mar 22, 2011 9:23 am

Hi Alec,
Thanks for the info, that patch does indeed resolve the issue talked about. Unfortunately there is still a problem:

Once the article is assigned to a proofreader, it does not show up in that proofreader's queue. I looked at the other patches in the list on the wiki and didn't notice anything that would fix this issue. Let me know if you need any additional info. Any help would be great.
Thanks,
- Jim
jbutler1
 
Posts: 13
Joined: Thu Oct 11, 2007 10:23 am

Re: Editing an article after an upgrade from ojs223 to ojs233

Postby asmecher » Tue Mar 22, 2011 9:29 am

Hi Jim,

Did you click the envelope icon under "Notify" to send the proofreader a notification email? This actually kicks off the assignment.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8673
Joined: Wed Aug 10, 2005 12:56 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: Yahoo [Bot] and 4 guests