OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Installation problem

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Installation problem

Postby cenkddr » Thu Jan 20, 2011 9:02 am

Hi,

We currently use OJS 2.2.2 without any problem. However, when we try to upgrade or install new version (2.3.3-3), we do experience a language problem.

The new version (2.3.3-3) perfectly works in any language, except Turkish.

How can we fix this problem? If you try to install this new version (2.3.3-3) in Turkish, I believe you will figure it out.

Thanks in advance for your help.


Cenk.
cenkddr
 
Posts: 5
Joined: Mon Sep 07, 2009 4:17 am

Re: Installation problem

Postby asmecher » Thu Jan 20, 2011 11:03 am

asmecher
 
Posts: 9090
Joined: Wed Aug 10, 2005 12:56 pm

Re: Installation problem

Postby cenkddr » Fri Jan 21, 2011 4:05 am

Hi,

Thanks for your quick reply. But, I want you to know that in this new version all the codes that you have mentioned (in classes/i18n/Locale.inc.php) are totally changed.

For this reason it is NOT possible to make your suggested change.

One more time, please try to install this new version in Turkish. I believe that you will experience the same problem that I have.

Thanks


Cenk.
cenkddr
 
Posts: 5
Joined: Mon Sep 07, 2009 4:17 am

Re: Installation problem

Postby asmecher » Fri Jan 21, 2011 9:32 am

Hi Cenk,

Yes, the code has moved. Please see my note at http://pkp.sfu.ca/support/forum/viewtopic.php?f=3&t=7065&p=27334#p27334.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9090
Joined: Wed Aug 10, 2005 12:56 pm

Re: Installation problem - Weird Solution

Postby muniponiz » Mon Mar 07, 2011 8:52 am

Hi,

I tried to install ojs-2.3.4.0 on my intranet server. All the locales were working - but Turkish.
"Stack Trace", "show php errors" were'nt working either.
Then I replaced the Turkish (tr_TR) localization files, with the files one of the other languages. Again no success...

After then I changed the locale name for Turkish (tr_TR) to tr_TK in /registry/locale.xml. I changed the tr_TR folder names in /locale, /lib/pkp/locale and in /plugins/ etc /locale to tr_TK and I edited all XML files in these directories (<locale name="tr_TK" full_name = "Türkiye Türkçesi">) . Now it works!!! But the Turkish locale key for OJS is now "tr_TK"!

The string "tr_TR" must have a meaning in the OJS code... I hope one of the developers see this.
muniponiz
 
Posts: 1
Joined: Mon Mar 07, 2011 8:37 am


Return to OJS Technical Support

Who is online

Users browsing this forum: Bing [Bot], Yahoo [Bot] and 7 guests