OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Error using link in reviewer invitation email

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Error using link in reviewer invitation email

Postby sjones » Mon Jan 17, 2011 7:08 pm

Since upgrading to 2.3.3-3 when a reviewer clicks on a submission URL in the invitation email that I send them, such as:

journalofblahblahblah.com/index.php/nms/reviewer/submission/5119

Instead of being sent to the login page they get an 404 - Not Found message with the URL:

journalofblahblahblah.com/index.php/nms/user/authorizationDenied?message=user.authorization.restrictedSiteAccess

If they log in before clicking on the submission URL the URL works and sends them to the review page, but prior to the upgrade they would have been sent to the login page, then, after logging in, they would have been sent to the review page.

I hope I'm making this clear, my apologies for any lack of clarity or confusion. Do let me know if I need to clarify.

Thank you,

Steve
sjones
 
Posts: 46
Joined: Sun Jan 29, 2006 8:47 am

Re: Error using link in reviewer invitation email

Postby sjones » Tue Jan 18, 2011 1:29 pm

I may have solved my own problem.

Since upgrading to 2.3.3-3, in the Journal Setup section that you get when you're Journal Manager, under Step 4: Managing the Journal, there's now a check box that says, "Users must be registered and log in to view the journal site." If that's unchecked it seems to work as it used to, and if it's checked then clicking on the URL brings up the 404 error. By default it seems to be checked, and I don't recall that it was even an option before (though I may well have forgotten if it was since it was quite a while ago that I set up the site).
sjones
 
Posts: 46
Joined: Sun Jan 29, 2006 8:47 am

Re: Error using link in reviewer invitation email

Postby asmecher » Tue Jan 18, 2011 1:39 pm

Hi Steve,

The 404 should actually be a proper "authorization denied" error message; see http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=6352 for a bug entry. However, if you've found a good work-around, that's great.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8347
Joined: Wed Aug 10, 2005 12:56 pm

Re: Error using link in reviewer invitation email

Postby sjones » Tue Jan 18, 2011 1:43 pm

So far as I can tell from testing it myself, what I described seems to have worked. Why it worked I have no idea, having looked at the bug report it seems to be exactly what I encountered!

Thanks,

Steve
sjones
 
Posts: 46
Joined: Sun Jan 29, 2006 8:47 am

Re: Error using link in reviewer invitation email

Postby asmecher » Tue Jan 18, 2011 2:14 pm

Hi Steve,

I created that bug entry based on your description here. Changing the authorization setting as you described means that you won't see the error message; if you don't need authorization to work the way it was previously set, that's a fine solution.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8347
Joined: Wed Aug 10, 2005 12:56 pm

Re: Error using link in reviewer invitation email

Postby rurallaw » Mon Sep 05, 2011 3:34 am

Hi all, thanks for the discussion. I'm having the same problem with OJS 2.3.4.0. If a user, who's submitted something for review, clicks on a link in an email while not logged they get the error message, after logging in, that says "You have been denied access. Access to this site is currently restricted".

The only way I can get rid of it is to uncheck the journal option that says "Users must be registered and log in to view the journal site". Is there any other way to get around this issue? Any help would be appreciated.
rurallaw
 
Posts: 8
Joined: Mon Sep 05, 2011 3:23 am

Re: Error using link in reviewer invitation email

Postby ramon » Wed Jan 11, 2012 1:10 pm

Hello all,

This is happening in 2.3.6, but email validation must be enabled AND the option "Users must register and login to view content published in this site".
Whenever only one is on/off, the error message disappears.
I have posted this on another topic, as I didn't find this one before.. please disregard the post to avoid duplicate discussions, if you wish...
ramon
 
Posts: 926
Joined: Wed Oct 15, 2003 6:15 am
Location: Brasí­lia/DF - Brasil

Re: Error using link in reviewer invitation email

Postby ramon » Fri Jan 13, 2012 9:09 am

Hello all,

I have posted here our user registration and login analysis, that may shed a light on what is happening.
ramon
 
Posts: 926
Joined: Wed Oct 15, 2003 6:15 am
Location: Brasí­lia/DF - Brasil


Return to OJS Technical Support

Who is online

Users browsing this forum: Google [Bot] and 3 guests