OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Errors post-upgrade

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Errors post-upgrade

Postby soj » Wed Feb 08, 2006 11:02 pm

Rats, not outta the woods yet. We are unable to upload a large submission. The file size is 6 mb. I can upload smaller files.

I tried increasing the memory limit in php.ini via htaccess:
php_value memory_limit 32M

Still no luck on large files.

Then I tried:

php_value upload_max_filesize 50M

That worked ;-)

However, I turned php errors display back on and got these errors in header. None in the footer.

Notice: Only variable references should be returned by reference in /home/ejssmorg/public_html/ojs/classes/core/Registry.inc.php on line 38

Notice: Only variable references should be returned by reference in /home/ejssmorg/public_html/ojs/classes/core/Registry.inc.php on line 38

Notice: Only variable references should be returned by reference in /home/ejssmorg/public_html/ojs/lib/adodb/adodb.inc.php on line 840

Notice: Only variable references should be returned by reference in /home/ejssmorg/public_html/ojs/lib/adodb/drivers/adodb-mysql.inc.php on line 659

Notice: Only variable references should be returned by reference in /home/ejssmorg/public_html/ojs/classes/core/DataObject.inc.php on line 45

Notice: Only variable references should be returned by reference in /home/ejssmorg/public_html/ojs/lib/adodb/drivers/adodb-mysql.inc.php on line 659

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /home/ejssmorg/public_html/ojs/classes/core/Registry.inc.php:38) in /home/ejssmorg/public_html/ojs/classes/session/SessionManager.inc.php on line 57

Notice: Only variable references should be returned by reference in /home/ejssmorg/public_html/ojs/lib/adodb/drivers/adodb-mysql.inc.php on line 659

Notice: Only variable references should be returned by reference in /home/ejssmorg/public_html/ojs/lib/adodb/drivers/adodb-mysql.inc.php on line 659

Warning: Cannot modify header information - headers already sent by (output started at /home/ejssmorg/public_html/ojs/classes/core/Registry.inc.php:38) in /home/ejssmorg/public_html/ojs/classes/template/TemplateManager.inc.php on line 179


Thoughts?

soj
soj
 
Posts: 151
Joined: Fri Oct 28, 2005 1:53 pm
Location: Norman OK USA

Postby asmecher » Thu Feb 09, 2006 12:45 am

Hi Soj,

Are you using Zend optimizer or another similar product? If so, try disabling it and see if that fixes the problem. Some versions optimize code like:
Code: Select all
function &myFunction() {
        $myVar = false;
        return $myVar;
}
into:
Code: Select all
function &myFunction() {
        return false;
}
which looks harmless enough, but in fact contravenes PHP's reference rules, resulting in warnings like the ones you mention.

At any rate, the warnings you mention are irritating but harmless -- if you can't track down what's causing them, just make sure warning messages aren't displayed and OJS will work fine.

Incidentally, what version of PHP are you using?

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 9050
Joined: Wed Aug 10, 2005 12:56 pm

Postby soj » Thu Feb 09, 2006 7:17 am

Zend? Yup!

PHP Version says 4.4.1.

And true, everything works as long as the error msgs are turned off. Thought you'd want to know, tho.
Thanks!

soj
soj
 
Posts: 151
Joined: Fri Oct 28, 2005 1:53 pm
Location: Norman OK USA

Postby asmecher » Thu Feb 09, 2006 11:21 am

Hi Soj,

Thanks for the info -- the problem here is an incompatibility between PHP 4.4.x and Zend Optimizer 2.5.10. There's a note on this problem at http://loudblog.de/forum/viewtopic.php?pid=1720 and http://bugs.php.net/bug.php?id=34009; I couldn't find anything official. As I mentioned, if you can't upgrade your PHP and/or Optimizer versions, hiding these error messages won't cause any problems.

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 9050
Joined: Wed Aug 10, 2005 12:56 pm

Postby Sherman » Sun Mar 19, 2006 11:50 am

asmecher wrote:At any rate, the warnings you mention are irritating but harmless -- if you can't track down what's causing them, just make sure warning messages aren't displayed and OJS will work fine.


I tried to install OJS and had similar Only variable references should be returned problems. I'll ask the ISP support to update the Zend optimizer, but in the meantime, I can't figure out how to turn off the warning messages. There doesn't seem to be such a toggle in the [debug] section of Config.inc.php. Help!
:!:
Sherman
 
Posts: 60
Joined: Sat Dec 10, 2005 8:18 pm
Location: Tampa, FL

How to disable Zend...

Postby Sherman » Sun Mar 19, 2006 3:37 pm

My ISP's support staff suggested putting the following in a file php.ini in the main OJS folder (where index.php and config.inc.php are):

register_globals = on
post_max_size = 20M
memory_limit = 80M
upload_max_filesize = 20M
max_execution_time = 120
expose_php=off

This is for systems where Zend is not turned on by default, and it simply repeats the system defaults (for me) for php. It worked!
Sherman
 
Posts: 60
Joined: Sat Dec 10, 2005 8:18 pm
Location: Tampa, FL

session auto start

Postby delong » Sun Mar 19, 2006 6:19 pm

I had the same problem with the post-install error messages in the header. Putting "session.auto_start=Off" in my php.ini file solved it.
delong
 
Posts: 13
Joined: Thu Dec 01, 2005 3:17 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: Bing [Bot], Exabot [Bot] and 3 guests