OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



upgrade problem

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

upgrade problem

Postby delong » Wed Feb 08, 2006 12:06 pm

Having some problems upgrading to 2.1.

I tried upgrading using the upgrade.php tool, but it kept failing (I believe my ftp server kept cutting off the connection in mid-patch).

So I uploaded the full 2.1 release, overwriting my old (backed up!) install. Problem is, I turn "installed" to "Off" in config.inc.php but it doesn't redirect to the install/upgrade page. I have OJS set up to redirect to our sole journal, so I thought that might be the problem. I don't have SSH access, and doing it via a cron job would leave the journal sitting buggy for hours. Any suggestions would be much appreciated!

Currently I have the backup copy up and running.
delong
 
Posts: 13
Joined: Thu Dec 01, 2005 3:17 pm

Postby asmecher » Wed Feb 08, 2006 12:51 pm

Hi delong,

It's not possible to run upgrade.php via an FTP connection. Have you tried the procedure described in http://pkp.sfu.ca/support/forum/viewtopic.php?t=691?

If you were upgrading from a pre-2.0.2 version of OJS, perhaps the upgrade failed because you were missing the general:base_path parameter in config.inc.php. See the template configuration file supplied with OJS 2.1.0-1. I'd suggest using the new configuration file as a template and moving your old settings into it -- several other options have been added as well.

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

yep

Postby delong » Wed Feb 08, 2006 12:56 pm

Sorry if I wasn't clear - yes, I did exactly that procedure. But instead of taking me to the upgrade/install page, it just goes to the normal journal page. I'm upgrading from 2.0.2.1. I'm stumped.

asmecher wrote:Hi delong,

It's not possible to run upgrade.php via an FTP connection. Have you tried the procedure described in http://pkp.sfu.ca/support/forum/viewtopic.php?t=691?

If you were upgrading from a pre-2.0.2 version of OJS, perhaps the upgrade failed because you were missing the general:base_path parameter in config.inc.php. See the template configuration file supplied with OJS 2.1.0-1. I'd suggest using the new configuration file as a template and moving your old settings into it -- several other options have been added as well.

Regards,
Alec Smecher
Open Journal Systems Team
delong
 
Posts: 13
Joined: Thu Dec 01, 2005 3:17 pm

Postby asmecher » Wed Feb 08, 2006 1:13 pm

Hi delong,

Have you tried flushing your browser cache and reloading the journal page? If "Installed" isn't set to "On", you should definitely not be seeing your journal's page. Please double-check your configuration file and try again; if you're still having trouble, feel free to send me your specifics at pkp-support@sfu.ca and I'll have a look.

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

fixed

Postby delong » Wed Feb 08, 2006 3:54 pm

I managed to fix the upgrade. I re-copied the 2.1 files and tried again. It worked this time. Thanks for the assistance!
delong
 
Posts: 13
Joined: Thu Dec 01, 2005 3:17 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: Yahoo [Bot] and 2 guests