OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Problems with the Reading Tools frame

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Problems with the Reading Tools frame

Postby nef » Fri Oct 08, 2010 6:49 am

Hi
Thank you for the new version 2.3.3.1. I'm looking forward to implement it on our server. At the time, I'm only testing and I have had problems showing the reading tools frame, and also the right section of the "normal" pages. When I'm opening an article it will only be presented as an ordinay pdf-file without the OJS surroundings and without the reading tools. I have ensured that the Reading tools are enabled.
How can that be solved?
Cheers
Niels Erik
nef
 
Posts: 234
Joined: Fri Jun 01, 2007 2:56 am
Location: Aarhus, Denmark

Re: Problems with the Reading Tools frame

Postby jmacgreg » Tue Oct 12, 2010 2:01 pm

Hi Niels,

The Reading Tools have been moved into the block plugin infrastructure, so you will have to enable them under Journal Setup Step 5.6. (We probably should've enabled this block by default on upgrade -- see http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=6034.)

Cheers,
James
jmacgreg
 
Posts: 4183
Joined: Tue Feb 14, 2006 10:50 am

Re: Problems with the Reading Tools frame

Postby nef » Wed Oct 13, 2010 7:19 am

Hi
How do I let the pdf-file also be presented including the Reading Tools. Now I can only show the pdfs in a full-screen mode
Cheers
Niels Erik
nef
 
Posts: 234
Joined: Fri Jun 01, 2007 2:56 am
Location: Aarhus, Denmark

Re: Problems with the Reading Tools frame

Postby jmacgreg » Wed Oct 13, 2010 10:30 am

Hi Niels,

The PDF file should load similarly to the HTML files -- that is, it should load in its own object box, with the Reading Tools (if enabled and set to display) also being displayed. Can you ensure that the PDFs are being properly detected as such on galley file upload, and could you send a screenshot of what you're seeing for PDFs?

Cheers,
James
jmacgreg
 
Posts: 4183
Joined: Tue Feb 14, 2006 10:50 am

Re: Problems with the Reading Tools frame

Postby nef » Tue Oct 19, 2010 3:52 am

Hi James
Sorry, it seems to be a problem related to my Internet Explorer 8 settings. Although I have installed the Adobe Reader the browser keeps on telling me to install it. In Firefox and Google Chrome there's no problem.
Cheers
Niels Erik
Attachments
adobe.gif
adobe.gif (10.53 KiB) Viewed 1392 times
nef
 
Posts: 234
Joined: Fri Jun 01, 2007 2:56 am
Location: Aarhus, Denmark

Re: Problems with the Reading Tools frame

Postby jmacgreg » Wed Oct 20, 2010 10:07 am

Hi Niels,

Strange. Does your IE 8 have problems opening other PDFs? Either way, could you send me a link to the site so that I can test with my own browser? (PM is fine.)

Cheers,
James
jmacgreg
 
Posts: 4183
Joined: Tue Feb 14, 2006 10:50 am

Re: Problems with the Reading Tools frame

Postby nef » Thu Oct 21, 2010 5:36 am

Hi
I still have problems :roll:
Becuse of the many screenshots I have chosen to upload a doc-file as attachment instead of writing here
Cheers
Niels Erik
Attachments
full view2.doc
(81 KiB) Downloaded 62 times
nef
 
Posts: 234
Joined: Fri Jun 01, 2007 2:56 am
Location: Aarhus, Denmark

Re: Problems with the Reading Tools frame

Postby jmacgreg » Mon Oct 25, 2010 9:54 pm

Hi Niels Erik,

Regarding the second screenshot: can you check to see if the full HTML is being loaded in the background? You can do this usually by clicking "View -> HTML Source" or similar in your browser. If the HTML is being loaded fully, but not being displayed properly, it may be this bug: http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=5521. If that's not the issue (and it's probably not), please let us know if an error is being reported in the background.

I'm not sure what's going on in the third screenshot. I'm actually wondering if all files have been uploaded properly. How did you set up this test server? Was it an upgrade of a copy of your production server? Further details would be appreciated.

Cheers,
James
jmacgreg
 
Posts: 4183
Joined: Tue Feb 14, 2006 10:50 am

Re: Problems with the Reading Tools frame

Postby nef » Tue Oct 26, 2010 5:01 am

Hi James
The full HTML is not being loaded in the background. The problem only occurs in connection with files derived from an earlier OJS version.
Cheers
Niels Erik
nef
 
Posts: 234
Joined: Fri Jun 01, 2007 2:56 am
Location: Aarhus, Denmark

Re: Problems with the Reading Tools frame

Postby mcrider » Fri Oct 29, 2010 2:02 pm

Hi Niels,

You may be experiencing the bug described at http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=6052. Please try applying the patch from that bug entry and trying again.

Cheers,
Matt
mcrider
 
Posts: 952
Joined: Mon May 05, 2008 10:29 am
Location: Vancouver, BC

Re: Problems with the Reading Tools frame

Postby tgc99 » Tue Nov 16, 2010 5:50 am

jmacgreg wrote:I'm not sure what's going on in the third screenshot. I'm actually wondering if all files have been uploaded properly. How did you set up this test server? Was it an upgrade of a copy of your production server? Further details would be appreciated.

Better late than never.

The server is running RHEL 5 with php 5.1.6 and postgres 8.1.22.

The instance that Niels-Erik is working with was done as a copy of a 2.2.4 site (DB and articles only) which was then updated to 2.3.3-1 using a fresh codebase (with bz#6023 and a local version of what became bz#6063).
It was then updated to 2.3.3-2 when it was released which introduced bz#6097.
After the fix for bz#6097 was released I restored the broken table and updated to 2.3.3-3.

Additionally there is a patch from bz#3865 applied (from comment#8 by Alec Smecher).

The software is managed by a git repository.
Since you suspect an incomplete installation I have verified that the diff between 2.3.3-3 and my current git repo is only the patch from bz#3865.

-tgc
tgc99
 
Posts: 56
Joined: Thu Oct 18, 2007 3:50 am
Location: Aarhus, Denmark

Re: Problems with the Reading Tools frame

Postby nef » Thu Nov 18, 2010 2:36 am

Hi
Perhaps I should ad, that the problems still exist. Hope you can help.
Cheers
NEF
nef
 
Posts: 234
Joined: Fri Jun 01, 2007 2:56 am
Location: Aarhus, Denmark

Re: Problems with the Reading Tools frame

Postby nef » Fri Jun 28, 2013 6:12 am

Hi
Can I draw your attention to this problem once more, please?
Some of our articles doesn't show up in the frame, but only gives you the opportunity to download it when you click the pdf link.
Here's one example:
http://ojs.statsbiblioteket.dk/index.ph ... /view/2575
In the same issue other articles opens up the right way in the frame. See:
http://ojs.statsbiblioteket.dk/index.ph ... /view/2225
Can you explane that? Very strange.
Regards
NEF
nef
 
Posts: 234
Joined: Fri Jun 01, 2007 2:56 am
Location: Aarhus, Denmark

Re: Problems with the Reading Tools frame

Postby asmecher » Fri Jun 28, 2013 8:23 am

Hi all,

I suspect the problem involves MIME types. Can you check the two articles' entries in the article_files table?
Code: Select all
SELECT f.file_id, f.file_type FROM article_galleys g, article_files f WHERE g.file_id = f.file_id AND g.galley_id IN (2575, 2225);
Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8345
Joined: Wed Aug 10, 2005 12:56 pm

Re: Problems with the Reading Tools frame

Postby tgc99 » Tue Jul 02, 2013 2:24 am

asmecher wrote:Hi all,

I suspect the problem involves MIME types. Can you check the two articles' entries in the article_files table?

Here are the results of the query:
Code: Select all
ojs=#     SELECT f.file_id, f.file_type FROM article_galleys g, article_files f WHERE g.file_id = f.file_id AND g.galley_id IN (2575, 2225);
 file_id |    file_type   
---------+-----------------
    9715 | application/pdf
   11242 | application/pdf
(2 rows)

The site is running OJS 2.3.7.
tgc99
 
Posts: 56
Joined: Thu Oct 18, 2007 3:50 am
Location: Aarhus, Denmark

Next

Return to OJS Technical Support

Who is online

Users browsing this forum: Google [Bot] and 2 guests