OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



upgrade problems (updated)

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

upgrade problems (updated)

Postby Klaas » Wed Sep 21, 2005 7:48 am

when using the command line tool:

Code: Select all
[wasabi]$ php tools/upgrade.php patch
Content-type: text/html
X-Powered-By: PHP/4.3.10

Failed to load version info from http://pkp.sfu.ca/ojs/ojs-version.xml


when using the patch file I get a bunch of errors:


from:

Code: Select all
patching file templates/submission/suppFile/suppFileView.tpl
can't find file to patch at input line 81959
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff -urN ojs-2.0.1/templates/t_compile/%%00^006^006265F5%%copyedit.tpl.php ojs-2.0.2/templates/t_compile/%%00^006^006265F5%%copyedit.tpl.php
|--- ojs-2.0.1/templates/t_compile/%%00^006^006265F5%%copyedit.tpl.php  2005-07-08 06:01:58.000000000 -0700
|+++ ojs-2.0.2/templates/t_compile/%%00^006^006265F5%%copyedit.tpl.php  2005-09-16 14:06:52.273314527 -0700
--------------------------
File to patch:
Skip this patch? [y] y
Skipping patch.
5 out of 5 hunks ignored


up till

Code: Select all
patching file templates/user/email.tpl


i get errors so i skip all files so far...
Klaas
 
Posts: 6
Joined: Thu Jul 07, 2005 7:53 am

Re: upgrade problems (updated)

Postby asmecher » Wed Sep 21, 2005 12:57 pm

Hi Klaas,

I'm not sure why you're getting an error message trying to fetch ojs-version.xml... I assume the machine you're running on has an un-proxied connection to the Internet? Have you tried again?

Regarding the patch errors, you should be able to skip the patches on all the templates/t_compile/... files. Afterwards, make sure to go into the Site Administrator interface and press the "Clear Template Cache" link.

However, all the .tpl files are required and you must patch them. Have you modified the templates since your original install of OJS? If so, you may need to go through some of the patches by hand. Please ensure that you've downloaded the correct patch for your version -- a full listing is available at http://pkp.sfu.ca/ojs/download/patch/.

Regards,
Alec Smecher
asmecher
 
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Re: upgrade problems (updated)

Postby kevin » Wed Sep 21, 2005 8:49 pm

Klaas wrote:when using the command line tool:

Code: Select all
[wasabi]$ php tools/upgrade.php patch
Content-type: text/html
X-Powered-By: PHP/4.3.10

Failed to load version info from http://pkp.sfu.ca/ojs/ojs-version.xml


This could happen if the allow_url_fopen php.ini setting is disabled.
kevin
 
Posts: 338
Joined: Tue Oct 14, 2003 8:23 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: Bing [Bot], Google [Bot], Yahoo [Bot] and 3 guests