OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Installation problems from the get-go

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Re: Installation problems from the get-go

Postby hsandir » Thu Apr 03, 2008 11:39 pm

Hi Siavash,

(I didn't see installation page yet and I stick tihs message.) I saw this error message:
DB Error: Table 'db240451381.journals' doesn't exist

Hakan


smiri wrote:Hi Hakan,

If you have access to your server error_logs, have you checked them to see what the problem is?

Also, you can add the line below to you index.php right after the <?php to see what the problem is.

<?php
ini_set('display_errors', E_ALL);

Regards,
hsandir
 
Posts: 6
Joined: Sat Nov 10, 2007 1:03 pm

Re: Installation problems from the get-go

Postby smiri » Sat Apr 05, 2008 5:48 pm

Hi Hakan,

Something doesn't make sense here. If the system isn't installed yet, then it shouldn't be looking for a DB table. Did you run the manual install script from the command line before?

I would suggest deleting all your files, and all you OJs databases and starting again from the beginning. Use a different directory and database names and try it again. If you run into the same problem again, please let me know exactly what you did, step by step so I can see what the problem is.

Try to follow the steps from http://pkp.sfu.ca/support/forum/viewtopic.php?f=8&t=2967 where applicable.

Regards,
smiri
 
Posts: 183
Joined: Thu Sep 06, 2007 7:01 pm

Re: Installation problems from the get-go

Postby asmecher » Sun Apr 06, 2008 12:49 am

Hi Hakan,

Alternately, turning on the "Debug" option in your config.inc.php file will result in more debugging information that might be of some help.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8337
Joined: Wed Aug 10, 2005 12:56 pm

Previous

Return to OJS Technical Support

Who is online

Users browsing this forum: Bing [Bot] and 3 guests