OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Installation Problem, Undefined index

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Installation Problem, Undefined index

Postby sedso » Fri Feb 29, 2008 2:09 am

Hi,

I am working with OJS, and tried to install it via web browser, I got "page cannot be displayed" error message, so I tried to install it via command-line installer.

While using command-line installer, I got "Successfully installed version 2.2.0.0" at the end, but I also got this error-message:

<b>Notice</b>: Undefined index: SCRIPT_NAME in <b>/home/www/at.uib.no/htdocs/ojs/classes/core/Request.inc.php</b> on line <b>101</b><br />
<br />
<b>Notice</b>: Undefined index: SCRIPT_NAME in <b>/home/www/at.uib.no/htdocs/ojs/classes/core/Request.inc.php</b> on line <b>180</b><br />

Now, it looks like as if OJS is installed but, none of links on the page are working, I am getting "Page cannot be displayed" error message for each of the links.

Here are the deatils:

OJS verison 2.2.0.0 is installed
(disable_path_info = On)
(database is installed as well)

Server: linux, PHP 4.3.2, MySql 3.23.58

URL: http://www.mywebsite.com/ojs

Any ideas?

Sedso
sedso
 
Posts: 5
Joined: Fri Feb 29, 2008 1:52 am

Re: Installation Problem, Undefined index

Postby smiri » Fri Feb 29, 2008 12:22 pm

Hi Sedso,

I assume you're using php-cgi / php-fastcgi on your server.

You should have a look at this post: http://pkp.sfu.ca/support/forum/viewtopic.php?f=3&t=2116&p=9757&hilit=script_name#p9757

This post is for OCS installation, but the server issues sound similar to your server problems.


Regards,
smiri
 
Posts: 183
Joined: Thu Sep 06, 2007 7:01 pm

Re: Installation Problem, Undefined index

Postby sedso » Sun Mar 02, 2008 4:37 am

Thank you very much for the quick response.

Unfortunately, it didnot work. Are there any other things that I can check regarding the codes or server configuration?

(OCS 2.0 is also installed on the same server and it is working properly.)

Sedso
sedso
 
Posts: 5
Joined: Fri Feb 29, 2008 1:52 am

Re: Installation Problem, Undefined index

Postby smiri » Mon Mar 03, 2008 11:56 pm

Hi Sedso,

can you check your error logs to see if you can find any more information on the errors?

Also, could you send me your config.inc.php file so I can have a look at it?

Thanks,
smiri
 
Posts: 183
Joined: Thu Sep 06, 2007 7:01 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: No registered users and 4 guests