OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



uploaded files don't appear [RESOLVED]

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

uploaded files don't appear [RESOLVED]

Postby graves » Wed Feb 27, 2008 11:35 am

I'm using IIS 6

I can create directories via Admin account, but when I upload any simple file it just doesn't work. No error, no file appears in Files Browser.

Permissions as per README are set.

README says "Create a directory to store uploaded files (submission files, etc.) and make this directory writeable." Which I did.

Then in the config.inc.php>Files section, it asks for "Complete path to directory to store uploaded files". Which I did, and I assume is the directory mentioned above.

Then it has "Path to the directory to store public uploaded files".

Is this referring to the /public folder within /ojs?

Insights appreciated.
graves
 
Posts: 8
Joined: Wed Feb 27, 2008 10:57 am

Re: uploaded files don't appear

Postby jmacgreg » Wed Feb 27, 2008 6:45 pm

Hi Graves,

I would suggest first following the steps outlined in the FAQ relating to blank pages or nothing happening:
viewtopic.php?f=8&t=2481

You should have two uploadable directories: /files, and /public. /files are for submission files, etc., and should not be directly web-accessible if you can help it.

Then in the config.inc.php>Files section, it asks for "Complete path to directory to store uploaded files". Which I did, and I assume is the directory mentioned above.

Then it has "Path to the directory to store public uploaded files".

Is this referring to the /public folder within /ojs?


Correct on both accounts. On the first count that, on Windows at least, it should be something like "C:\xampp\htdocs\ojs\files". Notice the slashes -- windows uses \ instead of / for directory structure. But if you managed to install the system fine, these should already be filled out for you.

Let me know if you receive anything from turning error reporting on as per the FAQ.

Cheers,
James
jmacgreg
 
Posts: 4190
Joined: Tue Feb 14, 2006 10:50 am

Re: uploaded files don't appear

Postby graves » Thu Feb 28, 2008 10:24 am

Thanks for the reply James.

I do have two uploadable directories, and both have permissions set as per README.

As admin, I can create directories fine but I simply cannot upload files so the steps outlined in the FAQ don't appear to relate the issue Im having.
I don't get a blank screen nor do I get an error. The screen just refreshes, and no file is displayed in the files browser. As far as I can tell everything that should be set up is set up and permissions as per README are correct. Im overlooking something obviously but am at my wits end as to what it is.
graves
 
Posts: 8
Joined: Wed Feb 27, 2008 10:57 am

Re: uploaded files don't appear

Postby jmacgreg » Thu Feb 28, 2008 10:48 am

Hi Graves,

Have you had luck uploading items from other areas of the interface -- Setup Step 5, for example, or author sumbission? The next thing I can think to check off the top of my head would be your memory limit settings as per <http://pkp.sfu.ca/support/forum/viewtopic.php?f=8&t=1382&p=4251&hilit=timeout#p4251>. You may want to try raising them and trying again. If that doesn't work, get back to me and I'll investigate further.

Cheers,
James
jmacgreg
 
Posts: 4190
Joined: Tue Feb 14, 2006 10:50 am

Re: uploaded files don't appear

Postby jmacgreg » Thu Feb 28, 2008 11:11 am

Also, disregard my note about using '\' for Windows -- PHP apparently will convert forward slashes to backslashes.

Cheers,
James
jmacgreg
 
Posts: 4190
Joined: Tue Feb 14, 2006 10:50 am

Re: uploaded files don't appear

Postby graves » Mon Mar 03, 2008 11:07 am

Hi James,

Yes I did get it figured out. The problem was our server admin had uploads disabled in PHP.ini. I thought they were on. Doh.

Anyhow, many thanks for your help.
graves
 
Posts: 8
Joined: Wed Feb 27, 2008 10:57 am


Return to OJS Technical Support

Who is online

Users browsing this forum: Google [Bot], Vhaeraun and 4 guests