OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Reading tools doesn't disappear [RESOLVED]

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

Reading tools doesn't disappear [RESOLVED]

Postby svillanueva » Wed Feb 27, 2008 3:36 am

Hi!

I've modified the templaets/article/article.tpl to show the part of the header when viewing an abstract, not including directly header.tpl but copying a little part of the code used there. I don't know whether this is the problem but now, when I open an abstract, the Reading Tools appears but, when I returned to Home page or whatever page, the Reading Tools keeps on the screen and does not disappear... then, if I try to open again an abstract, ANOTHER Reading tool appears, and so on... I think that making the first RT disappear, the problem will be solved as the new reading tool would be opened on the correct frame.

Any idea?



Thanks again,

Sergi Villanueva.
svillanueva
 
Posts: 74
Joined: Fri Jan 18, 2008 4:20 am
Location: Barcelona

Re: Reading tools doesn't disappear

Postby jmacgreg » Wed Feb 27, 2008 11:19 am

Hi Sergi,

I would suggest reverting your modifications to see if the problem disappears; if so, you'll have to find a different way to make the changes you want to do. You can post your efforts in the OJS Development forum for the community to comment upon, if you'd like.

Cheers,
James
jmacgreg
 
Posts: 4191
Joined: Tue Feb 14, 2006 10:50 am

Re: Reading tools doesn't disappear

Postby asmecher » Wed Feb 27, 2008 11:49 am

Hi Sergi,

The problem is probably due to a link from within the Reading Tools frameset that doesn't specify target="_parent" as part of the link. Make sure the target is specified and it should cause the link to jump out of the frameset.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Re: Reading tools doesn't disappear

Postby svillanueva » Thu Feb 28, 2008 4:34 am

Ok, i didn't realize that the navbar from header.tpl is different from the one used in article.tpl because, as Alec said, it need the target="_parent" attribute. It works, now.



Thank you!

Sergi Villanueva.
svillanueva
 
Posts: 74
Joined: Fri Jan 18, 2008 4:20 am
Location: Barcelona


Return to OJS Technical Support

Who is online

Users browsing this forum: Bing [Bot] and 1 guest