OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Restricting Access to Subscribers only

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Restricting Access to Subscribers only

Postby parasko » Mon Feb 25, 2008 7:43 pm

Hi all,

I wish to restrict access to our journal so that only subscribers can view the full articles. The journal and issues are already created and so I wish to do this retrospectively.

As an Editor, in the "Issue Data" section, I have chosen the option of 'Subscription' as the Access Status option. I have also chosen a date well into the future as the Open Access date option. These should be the correct settings to restrict access so that everyone can view the journal and the article abstracts but not the full articles. However, both subscribers and non-subscribers can view all articles.

What am I doing wrong? Can I not change the access option retrospectively? Is this something I can do only at the time the issue is initially created?

Please help.

Thanks.
parasko
 
Posts: 4
Joined: Wed Feb 20, 2008 10:10 pm

Re: Restricting Access to Subscribers only

Postby jmacgreg » Wed Feb 27, 2008 5:16 pm

Hi Parasko,

No, this should work fine. I would suggest double-checking a couple of things:

1. Make sure you log out to check whether subscriptions are working or not, and that you aren't attempting to test subscriptions from an allowed IP: management staff of the journal will not see any indications that subscriptions are working as they have full access to everything.

2. You may have to check on an article-by-article basis that subscriptions are enabled. You can do this as an editor: log in; go to User home --> Back Issues; choose the issue you want to check; make sure that under Issue Data you've chosen Subscription Access and that the date is in the future, and that under Table of Contents all subscription-protected articles are listed as default (which should be subscription) access. I understand that you have already done at least some of this, but it's probably best to double-check and ensure that you save any changes.

3. Make sure that you've set reasonable information in both Journal Setup Step 4.1 (you may want to check the checkbox that says "Always show galley links and indicate restricted access", although this isn't necessary) and under Journal Management User Home --> Subscriptions --> Subscription Policies.

Please let me know when you've checked these points, and we can troubleshoot further.

Cheers,
James
jmacgreg
 
Posts: 4190
Joined: Tue Feb 14, 2006 10:50 am


Return to OJS Technical Support

Who is online

Users browsing this forum: Google [Bot] and 2 guests

cron