OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



v2.2, HTML galleys, html_galley set to 0 [RESOLVED]

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

v2.2, HTML galleys, html_galley set to 0 [RESOLVED]

Postby smossbarger » Wed Feb 20, 2008 4:24 pm

Hi,

I believe there was previously a patch to fix this issue, but I can't find it, and anyway it might not be wise to reuse it.

If I upload an HTML galley file and label it as HTML in OJS Editor view, EDITING, at the Galley EDIT link, then click Save, OJS does not flip the switch in article_galleys.html_galley to 1, even though article_galleys.label is set to value "HTML". This does not seem to be a problem after the initial upload if after the initial upload I run a query in the database to update HTML labeled galley records, html_galley field, to 1 -- that is future uploads of the same galley file don't disturb the html_galley column value.

This means that when an HTML article is viewed, OJS does not generate/regenerate surrounding HTML markup, including DC metadata, etc.

This occurs whether the galley file is complete HTML (with an HTML opening and closing tag and no OJS-specific markup such as DIV#main or DIV#content) or partial HTML (using a pre-set article template that is meant to go inside the HTML BODY tag, and assumes that OJS will generate surrounding markup such as DIV#main, DIV#content, etc).

Thanks in advance for your assistance.
smossbarger
 
Posts: 11
Joined: Thu Nov 01, 2007 2:31 pm

Re: v2.2, HTML galleys, html_galley set to 0

Postby jmacgreg » Wed Feb 20, 2008 8:56 pm

Hi smossbarger,

Just to clarify a few things: you've recently upgraded to 2.2, correct? I'm guessing things were working properly beforehand? Have you upgraded anything else on your server recently?

I would suggest looking at the following post, and check whether the HTML files you are uploading should be getting picked up by your magic.mime file in the first place:

viewtopic.php?f=8&t=733&p=2599#p2599

If that checks out, send me one of the HTML files in particular, and I can have a look, or see if I can track down that patch (haven't found reference to it yet).

Cheers,
James
jmacgreg
 
Posts: 4181
Joined: Tue Feb 14, 2006 10:50 am

Re: v2.2, HTML galleys, html_galley set to 0

Postby jmacgreg » Wed Feb 20, 2008 9:11 pm

Hi smossbarger,

Was the following the post and patch you were referring to?

viewtopic.php?f=8&t=2110&p=7074

This has been added to OJS 2.2; but this isn't to say that you won't necessarily have issues when uploading HTML files, especially wrt your server recognizing them as such.

Let me know how if/when you make any progress.

Cheers,
James
jmacgreg
 
Posts: 4181
Joined: Tue Feb 14, 2006 10:50 am

Re: v2.2, HTML galleys, html_galley set to 0

Postby smossbarger » Thu Feb 21, 2008 9:51 am

Thanks James -- an Apache "mime" file edit did the trick. Sorry for my atrocious memory recall...

Best,
Stephen
smossbarger
 
Posts: 11
Joined: Thu Nov 01, 2007 2:31 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: No registered users and 2 guests