You are viewing the PKP Support Forum | PKP Home Wiki

HTML link won't show HTML but Article Download page

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

HTML link won't show HTML but Article Download page

Postby khellekson » Sun Dec 16, 2007 7:47 pm

http://journal.transformativeworks.org/ ... sue/view/1

The non-peer-reviewed sections, which do not have abstracts, will not publish to a real HTML page, the way the full-length (with abstract!) article does. Instead, I get the opportunity to download the file.

How can I force it to publish to a proper HTML page?

Posts: 14
Joined: Sun Nov 18, 2007 8:07 pm

Re: HTML link won't show HTML but Article Download page

Postby ramon » Mon Dec 17, 2007 6:09 am

Dear Karen,

HTML articles are usually displayed as PDF's are, in a specific frame, independent of the section and their configuration.

It's VERY odd that HTML behavior is inconsistent within one installation.

We had similar issues in a specific server when the HTML was NOT in UTF-8 encoding.
A server configuration prevented the wrongly-formatted HTML to download instead of display on the page.

Check if your HTML files are correctly encoded.

Hope this helps!

Good luck!

Posts: 945
Joined: Wed Oct 15, 2003 6:15 am
Location: Brasí­lia/DF - Brasil

Return to OJS Technical Support

Who is online

Users browsing this forum: Google [Bot] and 3 guests