OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



JavaScript broken; Comments without titles

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

JavaScript broken; Comments without titles

Postby khellekson » Tue Dec 04, 2007 8:10 am

We're starting a new open access media studies journal, HTML only, and I have managed to push a test article (http://journal.transformativeworks.org/ ... e/view/2/5) through the most recent version of the software to examine the results. I'm not the SysAdmin and I have only ftp privileges.

A couple questions:

1. In the right-hand Reading Tools bar, all the JavaScript links are broken and default to a 404. Where do I go to fix them? (The non-JS ones work fine.)

2. In Comments, if you don't enter a title, it elides the entry altogether and readers have to do a workaround to see the content. Is there some way to make it default to say "Comment" if the commenter doesn't input a title? That would then permit it to be hotlinked. The ability to comment is incredibly important to the readership and it must be intuitive and easy.

Thank you!

--Karen
khellekson
 
Posts: 14
Joined: Sun Nov 18, 2007 8:07 pm

Re: JavaScript broken; Comments without titles

Postby asmecher » Tue Dec 04, 2007 1:35 pm

Hi Karen,

1. See http://pkp.sfu.ca/support/forum/viewtopic.php?p=7733#p7733 for a patch for the Reading Tools issue.

2. That's a new bug; thanks for reporting. There is a patch for this at http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=3171; the patch may not apply cleanly against OJS 2.1.1, as it was generated against pre-2.2 CVS, but it should be easy to port.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8307
Joined: Wed Aug 10, 2005 12:56 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 7 guests