OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



createIssue fails with DB error

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

createIssue fails with DB error

Postby spatialguru » Fri Oct 19, 2007 8:26 am

My install of OJS has been working really well during set up. Until I try to create a new issue. It fails and says:
Code: Select all
DB Error: Unknown column 'label_format' in 'field list'


I haven't seen anything like this in OJS thus far and don't see anything in the forum or online talking about this.

Any pointers? I am running ojs-2.1.1.

Regards,
Tyler
spatialguru
 
Posts: 112
Joined: Mon Jun 25, 2007 1:23 pm
Location: British Columbia, Canada

Re: createIssue fails with DB error

Postby asmecher » Fri Oct 19, 2007 9:56 am

Hi Tyler,

That's very unusual. What is the version history? Have you run any other versions of OJS on that install, or modified the installation in any way?

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8613
Joined: Wed Aug 10, 2005 12:56 pm

Re: createIssue fails with DB error

Postby spatialguru » Fri Oct 19, 2007 11:14 am

asmecher wrote:That's very unusual. What is the version history? Have you run any other versions of OJS on that install, or modified the installation in any way?


That's a good question and unfortunately I don't know the answer because I didn't document it and I did a lot of testing. I would guess that I had installed CVS version at some point and then fell back to 2.1.1 , but I was sure I reloaded all the tables.

It's not an actively used instance yet, so now would be the time for me to reinstall it I think :)
spatialguru
 
Posts: 112
Joined: Mon Jun 25, 2007 1:23 pm
Location: British Columbia, Canada

Re: createIssue fails with DB error

Postby asmecher » Fri Oct 19, 2007 11:58 am

Hi Tyler,

Agreed. IIRC, the label_format field was added to CVS post-2.1.1 so it may be a remnant of your earlier CVS install. Unless you've invested a lot of time getting data etc. into this install, I'd suggest starting again. If you do have data in the installation, let me know what sort it is and I can suggest how to save what you can.

Best to correct it now, as sorting out what's what after you've gone live is much more difficult.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8613
Joined: Wed Aug 10, 2005 12:56 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: Yahoo [Bot] and 2 guests

cron