OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



patch 2.0.2 to 2.1.1 crashed site

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

patch 2.0.2 to 2.1.1 crashed site

Postby timmcgeary » Fri Sep 07, 2007 2:09 pm

I tried to install the patch for 2.0.2 to 2.1.1. by following the instructions on http://pkp.sfu.ca/ojs/UPGRADE. I did the $ patch -p1 < PATCH_FILE and now I am getting this error:

DB Error: Table 'verb.plugin_settings' doesn't exist

"Verb" is the one journal we have using OJS 2.x. I wanted to get OJS2.x upgraded to the latest stable release in preparation for moving over the journal that is still on 1.x. Why am I getting this error? I did find that the php memory_size issue after the fact and increased the memory size to 16M. But how do I get the journal back up and running?

Thanks,
Tim
timmcgeary
 
Posts: 29
Joined: Wed Aug 15, 2007 1:15 pm

Re: patch 2.0.2 to 2.1.1 crashed site

Postby asmecher » Fri Sep 07, 2007 2:17 pm

Hi Tim,

Is "Installed" set to "Off" in your config.inc.php? If it is, and you're still getting the error message about plugin_settings not existing, try commenting out the following line in includes/driver.inc.php:
Code: Select all
PluginRegistry::loadCategory('generic');
Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8479
Joined: Wed Aug 10, 2005 12:56 pm

Re: patch 2.0.2 to 2.1.1 crashed site

Postby timmcgeary » Fri Sep 07, 2007 3:25 pm

Alec,

Why set to Off? This is an upgrade, so shouldn't it be set to On because it is already installed?

It was set to On, so I changed it to Off and now it is re-directing me to the install page, but that is broken, too. Firefox is giving me a page not redirected properly error, but nothing in the apache error logs.

Tim
timmcgeary
 
Posts: 29
Joined: Wed Aug 15, 2007 1:15 pm

Re: patch 2.0.2 to 2.1.1 crashed site

Postby asmecher » Fri Sep 07, 2007 3:53 pm

Hi Tim,

From docs/UPGRADE:
2. Web

If you do not have the PHP CLI installed, you can also upgrade by running a
web-based script. To do so:

- Edit config.inc.php and change "installed = On" to "installed = Off"
- Open a web browser to your OJS site; you should be redirected to the
installation and upgrade page
- Select the "Upgrade" link and follow the on-screen instructions
- Re-edit config.inc.php and change "installed = Off" back to
"installed = On"
Try commenting out the line specified above and seeing if that helps. Then run the upgrade process quoted here.

Make sure you back up your database first, as your server may encounter PHP's execution time limits, memory limits and the like.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8479
Joined: Wed Aug 10, 2005 12:56 pm

Re: patch 2.0.2 to 2.1.1 crashed site

Postby timmcgeary » Fri Sep 07, 2007 8:00 pm

Alec,

I uncommented the Installed line in the config.inc.php file, but I am still not redirected fully to the Install/Upgrade page. The address changes to http://verb.lib.lehigh.edu/index.php/install, but nothing renders in the browser. Again there are no errors in the error log and simply a "GET /index.php/install HTTP/1.1" 302 in the access log, but it never completes.

So there seems to be another setting conflicting that won't let the install page render.

Tim
timmcgeary
 
Posts: 29
Joined: Wed Aug 15, 2007 1:15 pm

Re: patch 2.0.2 to 2.1.1 crashed site

Postby timmcgeary » Fri Sep 07, 2007 8:03 pm

FYI, I have redirected the URL of the backed up directory to the hostname in my virtual host definition, so if you try to go to the link I wrote before, you'll see a functioning site. I thought I accidentally trashed the backup directory, but found it so I want to be sure something is functional this weekend while there are time gaps in our replies to each other and the time I have available to work on this...
timmcgeary
 
Posts: 29
Joined: Wed Aug 15, 2007 1:15 pm

Re: patch 2.0.2 to 2.1.1 crashed site

Postby asmecher » Fri Sep 07, 2007 9:19 pm

Hi Tim,

Were you previously using an install with path_info_disabled turned On? If so, make sure that this option is also enabled in the upgraded install.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8479
Joined: Wed Aug 10, 2005 12:56 pm

Re: patch 2.0.2 to 2.1.1 crashed site

Postby timmcgeary » Sat Sep 08, 2007 6:55 am

Alec,

I turned that setting to On, and now I get the URL http://verb.lib.lehigh.edu/index.php?journal=install, but it still does not direct anywhere.

Tim
timmcgeary
 
Posts: 29
Joined: Wed Aug 15, 2007 1:15 pm

Re: patch 2.0.2 to 2.1.1 crashed site

Postby asmecher » Sat Sep 08, 2007 9:31 am

Hi Tim,

Hmm, you should definitely be seeing an error message or something to indicate what the problem is. Try adding the following to index.php to ensure that errors are displayed in the browser:
Code: Select all
ini_set('display_errors', E_ALL);
Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8479
Joined: Wed Aug 10, 2005 12:56 pm

Re: patch 2.0.2 to 2.1.1 crashed site

Postby timmcgeary » Sat Sep 08, 2007 6:38 pm

Alec,

I added that line to the top of the index.php file, within the <?php tage. Still no httpd error logged and this is the error I get in the browser:

The page isn't redirecting properly
Firefox has detected that the server is redirecting the request for this address in a way that will never complete.


I'm leaving the site as is so that you can see the error, too, if you'd like. http://verb.lib.lehigh.edu
timmcgeary
 
Posts: 29
Joined: Wed Aug 15, 2007 1:15 pm

Re: patch 2.0.2 to 2.1.1 crashed site

Postby timmcgeary » Mon Sep 10, 2007 8:48 am

Alec,

Since I have a directory with the original 2.0.2 files, should I just try to re-start the upgrade process? If so, could you lay out specifically which method I should do?

    $ patch -p1 < PATCH_FILE
    php tools/upgrade.php patch

Also, I realized that I had failed to run the DB upgrade portion of the document. I did that now, and I am getting this error now on the root level (with Installed turn On):

Fatal error: require() [function.require]: Failed opening required 'pages//index.php' (include_path='.:/home/local/ojs2/includes:/home/local/ojs2/classes:/home/local/ojs2/pages:/home/local/ojs2/lib:/home/local/ojs2/lib/smarty:.:/usr/share/pear') in /home/local/ojs2/index.php on line 39


Let me know if I should start over or if you think we can fix it from this point. You can see the error yourself at http://verb.lib.lehigh.edu/
timmcgeary
 
Posts: 29
Joined: Wed Aug 15, 2007 1:15 pm

Re: patch 2.0.2 to 2.1.1 crashed site

Postby asmecher » Mon Sep 10, 2007 9:23 am

Hi Tim,

Very odd. Would you be willing to let me investigate personally? If so, please PM me.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8479
Joined: Wed Aug 10, 2005 12:56 pm

Re: patch 2.0.2 to 2.1.1 crashed site

Postby asmecher » Mon Sep 10, 2007 1:07 pm

Hi all,

FYI, the problem related to a site-specific modification of the OJS 2.0.2 installation.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8479
Joined: Wed Aug 10, 2005 12:56 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: Bing [Bot], Google [Bot], Yahoo [Bot] and 3 guests