You are viewing the PKP Support Forum | PKP Home Wiki


Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.


Postby asmecher » Sat Jan 19, 2008 10:23 am

Hi Gunther,

Removing a plugin shouldn't cause this -- have you tried moving the entire plugins/generic/webFeed directory out of the OJS tree temporarily? Usually if the entire site goes blank it's because of a typo in the code (i.e. a missing "}" will sometimes cause PHP to die gracelessly and without warning). You can at least make sure that the problem is to do with plugins by removing the following line:
Code: Select all
...from includes/driver.inc.php. This will prevent OJS from loading the generic plugin category.

Alec Smecher
Public Knowledge Project Team
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm


Postby jmir » Sat Jan 19, 2008 11:23 am

Phew ... (sigh of relief).
Removing the webfeed directory did the trick - should have thought of this by myself. Obviously, just renaming the old plugin was a dummy idea.

At least the main site is running again. Still can't get the new WebFeed plugin to run.
I have settingsform.inc.php 1.7 and settingsform.tpl 1.4 [although the header of that file says 1.2] from the CVS installed, as well as the other files from the latest CVS
When I go to the plugin settings form as journal manager it just blanks out.
Posts: 74
Joined: Mon Feb 26, 2007 12:16 am


Postby smiri » Sat Jan 19, 2008 12:32 pm

Hi jmir,

like Alec mentioned above, there must be a error in your code somewhere.

you should be able to see the error by putting the line below in your index.php file right after the <?php line:

ini_set('display_errors', E_ALL);

Posts: 183
Joined: Thu Sep 06, 2007 7:01 pm


Postby jmir » Sat Jan 19, 2008 1:15 pm

Thanks for the hint regarding how to enable the display of errors....

I actually haven't touched the code, as I said before, I just installed the most recent plugin (the rest of the OJS codebase has NOT been touched, I am running partly pre-2.2.

The error msg I am getting when trying to access the SETTINGS in the plugin list

Code: Select all
Fatal error: Class 'FormValidatorPost' not found in /var/www/sites/jmir2.org/html/ojs/plugins/generic/webFeed/SettingsForm.inc.php on line 37

Another error I am getting on the homepage is

Code: Select all
Warning: Smarty error: unable to read resource: "file:/var/www/sites/jmir2.org/html/ojs/plugins/generic/webFeed/templates/links.tpl" in /var/www/sites/jmir2.org/html/ojs/lib/smarty/Smarty.class.php on line 1095

UPDATE 19/01/08 4pm: I followed the advice which I found here (viewtopic.php?f=8&t=2088) and commented out $this->addCheck(new FormValidatorPost($this));
however, as in Renate's case, the feed doesn't show (should be at http://www.jmir.org/feed/atom , right?). I tried both seetings (issue and last n articles), at no avail
Posts: 74
Joined: Mon Feb 26, 2007 12:16 am


Return to OJS Technical Support

Who is online

Users browsing this forum: Bing [Bot], Google [Bot], Yahoo [Bot] and 1 guest