You are viewing the PKP Support Forum | PKP Home Wiki

notification email fails

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

notification email fails

Postby jmir » Mon May 14, 2007 7:05 am

It seems the notification email is not being sent out (all other emails work).
I am not sure where I should start debugging.

I selected "Send this message to the users associated with this journal who have indicated that they wish to receive updates (17357 users)".

After clicking "send" the browser just goes into the "Loading..." state and remains there forever.

Is there any reason why this would fail due to the relatively large number of users?

Where should I start debugging?
Posts: 74
Joined: Mon Feb 26, 2007 12:16 am

Postby asmecher » Mon May 14, 2007 8:59 am

Hi Gunther,

This code has been rewritten for OJS 2.2 to indicate progress as it sends messages. In the meantime, the code works, but many servers are configured to prevent PHP scripts from running long enough to send that many messages. Make sure your max_execution_time and max_input_time limits are set extremely high in your server's php.ini configuration file.

Alec Smecher
Open Journal Systems Team
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Return to OJS Technical Support

Who is online

Users browsing this forum: Google [Bot] and 2 guests