OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



error -

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

error -

Postby jcer_editor » Sun May 13, 2007 5:49 am

Hi - I'm at a complete loss.

Our ojs journal was working perfectly until this morning when I discovered the following message:

Warning: Unexpected character in input: ' in /data01/jcer/public_html/ojs/cache/fc-locale-en_US.php on line 833

Warning: Unexpected character in input: ' in /data01/jcer/public_html/ojs/cache/fc-locale-en_US.php on line 833

Warning: Unexpected character in input: ' in /data01/jcer/public_html/ojs/cache/fc-locale-en_US.php on line 833

Warning: Unexpected character in input: ' in /data01/jcer/public_html/ojs/cache/fc-locale-en_US.php on line 833

Warning: Unexpected character in input: '' (ASCII=1) state=1 in /data01/jcer/public_html/ojs/cache/fc-locale-en_US.php on line 833

Warning: Unexpected character in input: ' in /data01/jcer/public_html/ojs/cache/fc-locale-en_US.php on line 833

Warning: Unexpected character in input: ' in /data01/jcer/public_html/ojs/cache/fc-locale-en_US.php on line 833

Warning: Unexpected character in input: ' in /data01/jcer/public_html/ojs/cache/fc-locale-en_US.php on line 833

Parse error: syntax error, unexpected T_STRING, expecting ')' in /data01/jcer/public_html/ojs/cache/fc-locale-en_US.php on line 833


I've found the file, but I've no idea how to fix it - can anyone help?

Thanks
jcer_editor
 
Posts: 10
Joined: Sun May 13, 2007 5:44 am

re: error

Postby mj » Sun May 13, 2007 6:04 am

Hi,

The first thing I would suggest is deleting the file in your /cache directory - in fact, you may want to delete all the fc-locale-* files in that directory; you can do so safely as long as you don't delete the sub-folders (_db, t_cache, t_compile, and t_config).

If deleting the cache resolves the problem, but there are warnings persisting, the other thing you may wish to do is to hide error messages. There are two ways to do this:

1) If you have access to modify your system's php.ini file (i.e. if you're running your own server), you can turn off the "display_errors" setting and turn on the "log_errors" setting; this is recommended for production environments anyway.

2) If you don't have access to modify php.ini, you can add the following statement near the top of index.php (making sure it's inside the <?php tag and outside of any comment blocks):

Code: Select all
ini_set('display_errors', 0);


Regards,
MJ Suhonos
Open Journal Systems Team
mj
Site Admin
 
Posts: 304
Joined: Fri Mar 26, 2004 9:32 am
Location: Toronto, Canada


Return to OJS Technical Support

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest

cron