OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Path indicator hyperlinks are not correct?

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Path indicator hyperlinks are not correct?

Postby rmichael » Tue May 08, 2007 10:40 am

I'm using OJS 2.1.1.

As a reviewer, and viewing the Review section for article ID #7, I'm at URL:
https://testhost/index.php/tj/reviewer/submission/13

At the top of the OJS screen, the navigation indicator displays the path:
Home > User > Reviewer > #7 > Review

The "#7" hyperlink points to the URL:
https://testhost/index.php/tj/reviewer/submission/7

However, that's the Review section for article ID #3.

Following the "#7" hyperlink to URL ".../submission/7", the navigation indicator displays the path:
Home > User > Reviewer > #3 > Review

The "#3" hyperlink points to the URL:
https://testhost/index.php/tj/reviewer/submission/3

If I click on it, I'm taken to Active Submissions, as the URL presumably doesn't exist. (There *is* a submission #3, as mentioned above, but it's the URL ending in "submission/7" that takes me there.)

Regarding hyperlinks in the navigation indicator, as reviewers appear to be constrained to the Review section for an article (i.e. they can't access the Summary, History or other sections pertaining to an article), the "#7" in the path indicator shouldn't really be a hyperlink at all (as it is for an editor, for example) because there is nothing for a reviewer to access "one level up".

If the "#7" *is* a hyper link, I think it should just point back to the current page (the Review section for article ID #7). It certainly shouldn't be a hyperlink taking me to the Review section for article ID #3.

I'm confused about the URL construction and the article ID # (I'm guessing sections are accessed by article # + offset, but I haven't looked at the code). However, OJS seems to be confused as well, and it simply trys to use the article number (ID #7) in the URL, leading to article ID #3.

Is this a bug, or am not understanding something?
rmichael
 
Posts: 113
Joined: Fri Mar 30, 2007 3:32 pm

Postby asmecher » Tue May 08, 2007 5:15 pm

Hi Richard,

On the Reviewer's side of things, the user is presented with article IDs (for consistency with the Editor's interface), but the numbers in the URLs are actually review assignment IDs. This is necessary because the same reviewer can be assigned to the same submission multiple times, e.g. for a multi-round review.

It looks like there's a bug in the breadcrumbs, where article IDs and review assignment IDs are confused. I'll file an entry in Bugzilla and correct this in OJS 2.2. (You might want to try the patch at http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=2823 if you don't want to wait that long.)

Regards,
Alec Smecher
Open Journal Systems Team
---
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
http://ocs.sfu.ca/pkp2007/
asmecher
 
Posts: 9220
Joined: Wed Aug 10, 2005 12:56 pm

Re: Path indicator hyperlinks are not correct?

Postby ramon » Wed Oct 03, 2007 5:41 am

Alec,

On another, not so related problem I think, the one-access click link is not working.
It gets stuck in the login page.
Is this related to the breadcrumb problem or something new?
ramon
 
Posts: 940
Joined: Wed Oct 15, 2003 6:15 am
Location: Brasí­lia/DF - Brasil

Re: Path indicator hyperlinks are not correct?

Postby asmecher » Wed Oct 03, 2007 7:59 am

Hi Ramón,

I assume you're talking about OJS 2.1.1. Could you describe the problem in a bit more detail? Do the URLs that reviewers are receiving contain an access key parameter? Do I understand correctly that these URLs, when followed, only lead to the login page? And is there a chance that they have expired (which takes two weeks from the time the message is sent)?

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9220
Joined: Wed Aug 10, 2005 12:56 pm

Re: Path indicator hyperlinks are not correct?

Postby ramon » Wed Oct 03, 2007 8:52 am

So sorry Alec,

We got confused with the Layout Editor, instead of the reviewer.

The reviewer one-click access is working fine...

By the way, I think some of the breadcrumbs need a bit of attention. During the editorial process (I don't recall exactly where, but I'll post it later) some of the links don't go where you'd expect, making the editor have to return to the submission list instead of the submission been treated, especially where there is no cancel button...
ramon
 
Posts: 940
Joined: Wed Oct 15, 2003 6:15 am
Location: Brasí­lia/DF - Brasil

Re: Path indicator hyperlinks are not correct?

Postby asmecher » Wed Oct 03, 2007 9:35 am

Hi Ramón,

A number of minor tune-ups have gone into CVS to deal with breadcrumbs and unusual redirections e.g. when saving forms. If you spot one you'd like to let us know about, post it here -- but hopefully they will have already been corrected.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9220
Joined: Wed Aug 10, 2005 12:56 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: Yahoo [Bot] and 7 guests