OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



published articles are not archived / still "in editing

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

published articles are not archived / still "in editing

Postby jmir » Fri May 04, 2007 1:46 pm

I am still having significant problems with articles imported from OJS1 (I assume that it is only an issue for these articles).

After publishing these articles, they were not removed from the editing queue. Isn't the intended behaviour that once you publish something it is archived automatically?

So I went to archive them manually by clicking the archive link in the Summary tab.

Unfortunately, this also removed them from the table of contents of the published and forthcoming issues!

So I rescheduled them for publication (some in the current issue, some in the forthcoming issue), which brought them back into the "in editing" queue, even though they are already published!

Is this a bug or a feature?

(See also viewtopic.php?p=5914
As described elsewhere, I also have problems with declining "under review" papers which are not being archived - I decline a paper, the status line goes to "queued for editing" and the paper not showing up in any of the views (archived, in editing, etc.).

1) Is there anything I can do by directly editing the database tables to remove the published papers from the "in editing" queue without deleting them from the table of contents?

2) Is there anything I can do by directly editing the database tables to lead to the intended behaviour (articles are archived and marked as declined) when I decline a paper?
jmir
 
Posts: 74
Joined: Mon Feb 26, 2007 12:16 am

Postby asmecher » Fri May 04, 2007 2:18 pm

Hi Gunther,

This is behavior that will be fixed in OJS 2.2. It behaves this way by design (i.e. it's not a bug), but we've revised the design because people are often finding themselves in your situation.

In OJS 2.1.1, published submissions don't move into the Archive until 1) they're scheduled against an issue and 2) the layout editor has been acknowledged in the proofreading stage.

For OJS 2.2, the second condition will be removed and submissions will move into the Archive when the issue they appear in is published.

Regards,
Alec Smecher
Open Journal Systems Team
---
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
http://ocs.sfu.ca/pkp2007/
asmecher
 
Posts: 8902
Joined: Wed Aug 10, 2005 12:56 pm

Postby jmir » Fri May 04, 2007 4:34 pm

Thanks, I'll try that (acknowledging the layout editor).

Also, I just realized that this strange behaviour when I decline articles they are NOT archived and appear in none of the tabs has nothing to do with import from OJS1, but also for new articles. What am I missing here?
jmir
 
Posts: 74
Joined: Mon Feb 26, 2007 12:16 am

Postby jmir » Fri May 04, 2007 5:02 pm

I acknowledged the layout editor and scheduled the article, but it is still sitting under "in editing". Are there other conditions that need to be met?

asmecher wrote:Hi Gunther,

This is behavior that will be fixed in OJS 2.2. It behaves this way by design (i.e. it's not a bug), but we've revised the design because people are often finding themselves in your situation.

In OJS 2.1.1, published submissions don't move into the Archive until 1) they're scheduled against an issue and 2) the layout editor has been acknowledged in the proofreading stage.

For OJS 2.2, the second condition will be removed and submissions will move into the Archive when the issue they appear in is published.

Regards,
Alec Smecher
Open Journal Systems Team
---
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
http://ocs.sfu.ca/pkp2007/
jmir
 
Posts: 74
Joined: Mon Feb 26, 2007 12:16 am

Postby asmecher » Fri May 04, 2007 5:09 pm

Hi Gunther,

This is all part of the same issue, which will be changed in OJS 2.2. Did you acknowledge the Layout Editor in the Layout Editing section or the Proofreading section? It's the Proofreading section that counts, in this case.

Regards,
Alec Smecher
Open Journal Systems Team
---
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
http://ocs.sfu.ca/pkp2007/
asmecher
 
Posts: 8902
Joined: Wed Aug 10, 2005 12:56 pm

Postby jmir » Fri May 04, 2007 10:36 pm

Thanks for the rapid response, Alec, you are great.

Yes, I acknowledged him in the proofreading stage. I then even rescheduled the article for TBA, and then back to the forthcoming issue, but it is still in the editing queue.

I can't put my journal operation on hold until 2.2. comes out - are there any quick fixes or workarounds?

asmecher wrote:Hi Gunther,

This is all part of the same issue, which will be changed in OJS 2.2. Did you acknowledge the Layout Editor in the Layout Editing section or the Proofreading section? It's the Proofreading section that counts, in this case.

Regards,
Alec Smecher
Open Journal Systems Team
---
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
http://ocs.sfu.ca/pkp2007/
jmir
 
Posts: 74
Joined: Mon Feb 26, 2007 12:16 am

Postby asmecher » Sat May 05, 2007 10:57 am

Hi Gunther,

Hmm... What version of OJS are you running? I'll double-check the conditions in the code for that version and get back to you.

Regards,
Alec Smecher
Open Journal Systems Team
---
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
http://ocs.sfu.ca/pkp2007/
asmecher
 
Posts: 8902
Joined: Wed Aug 10, 2005 12:56 pm

Postby jmir » Mon May 07, 2007 2:56 pm

the latest CVS version of OJS, pre- release of OJS 2.2. This was done because there were some important features added after 2.1.1 which we need and we could not wait until 2.2.

asmecher wrote:Hi Gunther,

Hmm... What version of OJS are you running? I'll double-check the conditions in the code for that version and get back to you.

Regards,
Alec Smecher
Open Journal Systems Team
---
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
http://ocs.sfu.ca/pkp2007/
jmir
 
Posts: 74
Joined: Mon Feb 26, 2007 12:16 am

Postby asmecher » Mon May 07, 2007 3:40 pm

Hi Gunther,

Ah, this makes things somewhat difficult if you've customized your installation. I'd suggest making sure that you're running the most recent CVS versions of:
  • classes/submission/sectionEditor/SectionEditorSubmissionDAO.inc.php
  • classes/submission/editor/EditorSubmissionDAO.inc.php
  • classes/submission/sectionEditor/SectionEditorSubmission.inc.php
  • classes/submission/editor/EditorSubmission.inc.php
This might correct the problem.

Regards,
Alec Smecher
Open Journal Systems Team
---
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
http://ocs.sfu.ca/pkp2007/
asmecher
 
Posts: 8902
Joined: Wed Aug 10, 2005 12:56 pm

DB way?

Postby mbria » Fri Jul 06, 2007 10:43 am

Dear Alec et al,

We found the same issue so we followed your suggestion with the OJS interface, but we aren't able to ACK the proofreading as Layout Editor and Section Editor is still viewing (to Edit) articles that are published in our last magazine.

Any case, is there any way to fix this changing the DB registers?

We reviewed the full database and looks like a simple datestamp in every field of proof_assignments' table will do the work... but we tested and it didn't.

Did we missed any other table or any other field?

Thanks a lot in advance for your help,

m.
mbria
 
Posts: 307
Joined: Wed Dec 14, 2005 4:15 am

Postby asmecher » Fri Jul 06, 2007 12:04 pm

Hi mbria,

If you're using OJS 2.1.1, you need to enter a value in the date_layouteditor_acknowledged column of the proof_assignments table for each article. This should cause published submissions to move to the archive.

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 8902
Joined: Wed Aug 10, 2005 12:56 pm

perfect solution !!

Postby mbria » Fri Jul 13, 2007 3:58 am

Sorry for the delay with my feedback.

Yes, it worked like a charm.
Easy and fast, without any collateral problems.

Thanks a lot Alec. We were very worried about this issue.

Best regards,

m.
mbria
 
Posts: 307
Joined: Wed Dec 14, 2005 4:15 am

Postby asmecher » Fri Jul 13, 2007 7:38 am

Hi mbria,

Great, glad to hear it -- FYI, the requirement for this field will be removed in OJS 2.2; it won't hold submissions from moving into the archive anymore.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8902
Joined: Wed Aug 10, 2005 12:56 pm

Thanks

Postby mbria » Wed Jul 25, 2007 5:30 pm

Sorry for the lag... I didn't read the forum for a while and I missed the post notification.

Thanks to explain Alec. Any case, is nice the solution is posted in the forum, just in case other users with versions prior to 2.2 find the same issue, don't you think? ;-)

Cheers,

m.
mbria
 
Posts: 307
Joined: Wed Dec 14, 2005 4:15 am

Archiving unwanted articles

Postby ramon » Thu Sep 06, 2007 12:16 pm

Alec,

How do I remove a "test" submission?
After going through the complete editorial process, there's no option to "Archive" the article, only publish it.
The review process is unavailable also, so I can't choose "reject" article to move it to the Archive?

What am I missing????
ramon
 
Posts: 931
Joined: Wed Oct 15, 2003 6:15 am
Location: Brasí­lia/DF - Brasil

Next

Return to OJS Technical Support

Who is online

Users browsing this forum: Bing [Bot] and 6 guests