OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Problems Uploading

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

Postby sean » Mon Apr 02, 2007 2:37 pm

Thanks Alec,

That seems to be the problem as when I try to upload a file I now see a "Permissions denied" error. However, I've set the ojs data directory to 777 and still get that error. The error also says that it failed to open the stream for: public/journals/2/homeHeaderLogoImage.jpg. Is "public" the ojs data directory or another directory?

OJS has previously been able to write submitted articles to the data directory, so I'm not sure what's the problem now. Any ideas?

Thanks again
sean
 
Posts: 37
Joined: Thu Mar 15, 2007 3:25 pm

Postby sean » Mon Apr 02, 2007 2:50 pm

Ok it seems to be working now that we changed the directory owner to the web server. However it still doesn't allow uploads of css files. Invalid file type error again.
sean
 
Posts: 37
Joined: Thu Mar 15, 2007 3:25 pm

Postby asmecher » Mon Apr 02, 2007 4:05 pm

Hi Sean,

You'll have to follow the same process here -- establish whether or not the .css file type is being properly detected. Sometimes the mime magic database will have trouble recognizing .css files that begin with comments; if any comments appear at the beginning of your stylesheet, try removing them.

Regards,
Alec Smecher
Open Journal Systems Team
---
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
http://ocs.sfu.ca/pkp2007/
asmecher
 
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Postby sean » Tue Apr 03, 2007 9:13 am

Hi Alec,

I was able to get the css upload to work by changing the following line in "JournalSetup5Form.inc.php"

Code: Select all
if ($type != 'text/plain' && $type != 'text/css') {return false}


to


Code: Select all
if ($type != 'text/plain' && $type != 'text/plain; charset=us-ascii' && $type != 'text/css') {return false}


Thanks for the help!
sean
 
Posts: 37
Joined: Thu Mar 15, 2007 3:25 pm

Previous

Return to OJS Technical Support

Who is online

Users browsing this forum: Yahoo [Bot] and 2 guests