OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



404 errors for "How to cite item" and other tools

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

404 errors for "How to cite item" and other tools

Postby bess » Mon Jan 29, 2007 11:31 am

We are using OJS 2.1.1.0 and we are just in the process of moving some of our journals over to it. Mostly it is working very well, but when viewing an individual article, several of the links on the right side of the page give 404 errors. These links are "How to cite item", "Indexing metadata", "Print version", ... well, all of them except "Review policy" and "Add comment."

OJS is running on RedHat Linux, apache httpd 2.0.52, with mysql v. 4.1.20, and php v. 4.3.9.

404 usually means a missing file, so I checked my httpd logs and they weren't too useful, even after I turned logging up to "debug" level:
[client 128.143.193.244] OJS: 404 Not Found, referer: http://francesca.lib.virginia.edu/ojs/i ... ewRST/1/26

There must be some way to decipher this so I can track down the problem, but so far I'm coming up blank. Has anyone else run into this? I'm new to OJS. Where should I start looking?

Thanks in advance,
Bess
bess
 
Posts: 3
Joined: Mon Jan 29, 2007 10:41 am
Location: Charlottesville, VA

Postby asmecher » Mon Jan 29, 2007 1:23 pm

Hi Bess,

See http://pkp.sfu.ca/support/forum/viewtopic.php?t=1539 for more information and a fix.

Regards,
Alec Smecher
Open Journal Systems Team
---
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
http://ocs.sfu.ca/pkp2007/
asmecher
 
Posts: 8334
Joined: Wed Aug 10, 2005 12:56 pm

hooray, it worked!

Postby bess » Mon Jan 29, 2007 2:22 pm

Thanks, Alec. That did the trick.
Here's what I did, for the benefit of future readers:
1. On OJS installation, go to $OJS_HOME/pages/rt
2. Open RTHandler.inc.php and see what version is listed in the $Id line. Mine, for example, was v. 1.35
3. Go to http://pkp.sfu.ca/cvs/cvsweb.cgi/ojs2/p ... 36;r2=1.37 (the link provided in Alec's message) but edit the url so that the version number of the first number is the same as the version number of YOUR file. For example, I had to edit the url to this (replacing the 1.36 with 1.35)
http://pkp.sfu.ca/cvs/cvsweb.cgi/ojs2/p ... 35;r2=1.37
4. Copy the whole page and paste it into a file on the server where you have OJS.
5. patch the RTHandler.inc.php like this:
patch RTHandler.inc.php /path/to/patchfile

That's what worked for me.
bess
 
Posts: 3
Joined: Mon Jan 29, 2007 10:41 am
Location: Charlottesville, VA


Return to OJS Technical Support

Who is online

Users browsing this forum: Bing [Bot], jmacgreg and 6 guests