You are viewing the PKP Support Forum | PKP Home Wiki

problem with directories for journal

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

problem with directories for journal

Postby jasonnolan » Thu Jan 04, 2007 3:48 pm

When we set up our 2.x system, we had a 1.1.9 version running on the same server /journal/ for 1.1.9 and /journal2007 for 2.x. I set it up fine, imported from old to new. Then copied /journal/ to /journal.old/ and /journal2007 to journal. No problem, except we noticed that some of the urls stuck to the old system for example If you're on this page:
<http://www.theharrow.com/journal/index.php/journal/information/authors> and
click on "register," you get a page not found alert for
<http://theharrow.com/journal2007/index.php/journal/user/register>; ditto if
you click on "log in"; the missing page is

I did a temporary fix of ln -s journal journal2007 to allow users to register, but this still leads to confusion.

Where can i go to check that there aren't legacy old urls? And or which files would have this problem so I can fix them manually?


Posts: 34
Joined: Sun Dec 12, 2004 2:59 am

Postby asmecher » Thu Jan 04, 2007 11:51 pm

Hi Jason,

There are a few places to check:
  • In config.inc.php
  • In your Journal Setup pages if you've entered any URLs manually, typically on page 5.
Otherwise, OJS should start using the new address without any changes.

Alec Smecher
Open Journal Systems Team
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Return to OJS Technical Support

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 3 guests