OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Search problem

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

Search problem

Postby Inna » Mon Dec 11, 2006 8:27 am

I just upgraded OJS 2.0 to version 2.1.1.
Everything seems to be working fine except search.
As far as I can tell the reason for search not working is that article_search_object_keywords, article_search_objects are empty.
I didn’t have any error messages while upgrading the database.
So, the question is how do I populate those tables, so search works again.
Thank you for any help.
Inna
 
Posts: 11
Joined: Mon Dec 04, 2006 11:51 am

Postby asmecher » Mon Dec 11, 2006 10:45 am

Hi Inna,

First, if you're using PDF articles, make sure that the text extraction tools in config.inc.php are properly configured; see the index[application/pdf] directive.

You can then re-generate the index using the tools/rebuildSearchIndex.php script.

Regards,
Alec Smecher
Open Journal Systems Team
---
Don't miss the First International PKP Scholarly Publishing Conference
July 11 - 13, 2007, Vancouver, BC, Canada
http://ocs.sfu.ca/pkp2007/
asmecher
 
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Postby Inna » Mon Dec 11, 2006 11:42 am

Thank you, Alec
Inna
 
Posts: 11
Joined: Mon Dec 04, 2006 11:51 am


Return to OJS Technical Support

Who is online

Users browsing this forum: Google [Bot] and 2 guests