OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Image Uploading Error

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Image Uploading Error

Postby abhiram » Fri Oct 13, 2006 3:54 am

Hi,
currently , am using ojs 1.11, but i couldnt upload jpeg file as journal image ( we are using shared server ) . The errors are


Warning: mkdir(public/journals/4): Permission denied in /home/ejtropag/public_html/classes/file/FileManager.inc.php on line 234

Warning: move_uploaded_file(public/journals/4/homeHeaderTitleImage.jpg): failed to open stream: No such file or directory in /home/ejtropag/public_html/classes/file/FileManager.inc.php on line 95

Warning: move_uploaded_file(): Unable to move '/tmp/phpZNtNbi' to 'public/journals/4/homeHeaderTitleImage.jpg' in /home/ejtropag/public_html/classes/file/FileManager.inc.php on line 95

Warning: Cannot modify header information - headers already sent by (output started at /home/ejtropag/public_html/classes/file/FileManager.inc.php:234) in /home/ejtropag/public_html/classes/template/TemplateManager.inc.php on line 187


Looking forward your reply

Thanks and Regards
Abhiram. H
abhiram
 
Posts: 30
Joined: Thu Aug 03, 2006 7:31 am
Location: India

Postby asmecher » Fri Oct 13, 2006 5:38 am

Hi Abhiram,

It looks like your "public" directory is not writable by the web server. Check to make sure that it has write access to the public directory and its contents and any subdirectories (e.g. using chmod -R ...). Additionally, if you're still using a host with the safe mode UID check (see http://pkp.sfu.ca/support/forum/viewtopic.php?p=3942), you'll still have to correct this problem before OJS will properly be able to create directories.

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 8470
Joined: Wed Aug 10, 2005 12:56 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: Bing [Bot], Yahoo [Bot] and 3 guests