You are viewing the PKP Support Forum | PKP Home Wiki

No search results with Lucene Search Plugin

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

No search results with Lucene Search Plugin

Postby jamilj » Mon Jul 21, 2014 11:58 pm


I worked on getting the Lucene Search Plugin working for several hours. It was surprisingly easy to set it up. I just followed the README file closely and was easily able to get JETTY installed and SOLR up and running. I already had Java version "1.6.0_28" running. Unfortunately, I was never able to get any search results. I have subscriber only content so I made sure to create an institutional subscriber with my server's IP address. After deleting the cache as well as the files/lucene folder, starting and stopping SOLR and re-running "php rebuildSearchIndex.php" a number of times, I was still not able to get any results. I have run out of things to do. Here is the output of solr-java.log:

Code: Select all
2014-07-22 02:42:36.414:INFO::Logging to STDERR via org.mortbay.log.StdErrLog
2014-07-22 02:42:36.531:INFO::jetty-6.1.26
2014-07-22 02:42:36.573:INFO::Extract file:~/public_html/archives_ojs/plugins/generic/lucene/lib/apache-solr-3.6.2/example/webapps/solr.war to /tmp/Jetty_127_0_0_1_8983_solr.war__solr__x48438/webapp
Jul 22, 2014 2:42:37 AM org.apache.solr.core.SolrCore initIndex
WARNING: [ojs] Solr index directory '~/files/lucene/data/index' doesn't exist. Creating new index...
2014-07-22 02:42:38.349:INFO::Started SocketConnector@
2014-07-22 02:47:51.494:INFO::Shutdown hook executing
2014-07-22 02:47:51.499:INFO::Graceful shutdown SocketConnector@
2014-07-22 02:47:51.500:INFO::Graceful shutdown org.mortbay.jetty.webapp.WebAppContext@152d61ea{/solr,file:/~/public_html/archives_ojs/plugins/generic/lucene/lib/apache-solr-3.6.2/example/webapps/solr.war}
2014-07-22 02:47:52.500:INFO::Stopped SocketConnector@
2014-07-22 02:47:52.621:INFO::Shutdown hook complete

I shut Lucene down and went back to the default plugin, which explains the shut down. If anyone can provide any suggestions, I would be grateful.
Posts: 44
Joined: Sun Aug 25, 2013 10:36 pm

Re: No search results with Lucene Search Plugin

Postby swing » Tue Jul 22, 2014 8:26 am

Hi jamilj,

Have you seen something like the following line, when you rebuild the search index:
# LucenePlugin: Indexing "you journal name" ... X articles indexed

Could you please use the Solr admin interface to see if there are indexed documents there? -- See this forum post/answer how to do it: viewtopic.php?f=8&t=9359&start=15#p43052

Are there any errors in your apache log file?

Posts: 157
Joined: Tue Oct 09, 2007 2:59 am

Return to OJS Technical Support

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 2 guests