OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Problems with the configuration of OJS and OAI

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

Problems with the configuration of OJS and OAI

Postby lartur » Wed Jul 16, 2014 9:17 am

Dear All,

I have quite some serious problems with OAI, and tried pretty much every configuration step:
https://www.ambientmediaassociation.org ... b=Identify
-> identify works, but I don't get any records

My configuration is a godaddy server, and I have the following configuration:
1) php5.ini in the home directory of OJS with the line cgi.fix_pathinfo = On
2) .htaccess file with:
Options FollowSymLinks
AcceptPathInfo On
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^(series)(.*)$ /Journal/index.php/$1$2 [L]

RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule ^(.*)$ /Journal/index.php/index/$1 [L]
</IfModule>
3) config.ini.php
base_url = "http://www...../Journal"
disable_path_info = Off
base_url[index] = "http://www..../Journal
base_url[series] = "http://www .../Journal/series
restful_urls = On
-> the oai section of the config file is also populated

I tried:
disable_apth_info = On
no base_url[index] and no base_url[series]

Questions:
- how do i get oai running?
- could it be that I have any problems with any of the OJS settings?
- are the above parameters correct?
... I simply don't get this to work, and I really would appreciate some help from your side :) Thanks'a'million in advance...
lartur
 
Posts: 2
Joined: Wed Jul 16, 2014 8:41 am

Re: Problems with the configuration of OJS and OAI

Postby asmecher » Wed Jul 16, 2014 9:40 am

Hi lartur,

I see records here:
https://www.ambientmediaassociation.org ... fix=oai_dc

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Re: Problems with the configuration of OJS and OAI

Postby lartur » Thu Jul 17, 2014 7:52 am

Dear All,

thanks for the response - yes it's working now, as one update script did not get applied. I will compile all the information into one forum entry for others, who have the same problem.

however, the re-write rules don't work yet - does anyone have a suggestion what could be wrong?

As soon as I collected this issue, I will compile the full answer together, and post it to the forum (including the reason why it did not work in my case). the solution was simply to apply a script in tools (XMLtoSQL) for indexing, and then it worked. Full solution coming, as soon as someone helps me with the url rewrites :)

thanks for the quick reply!
lartur
 
Posts: 2
Joined: Wed Jul 16, 2014 8:41 am

Re: Problems with the configuration of OJS and OAI

Postby ctgraham » Thu Jul 17, 2014 11:30 am

Can you be more specific about what is not working with the rewrite rules?

As a note, %{REQUEST_FILENAME} does not work correctly for me under Apache 2.2.15 running on Oracle Enterprise Linux 6.5 (Redhat-based). I've had to work around it with %{DOCUMENT_ROOT} %{REQUEST_URI} combinations.

Also, I'd be a bit concerned that you are applying the second rewrite to anything, including subrequests of the first rewrite. If %{REQUEST_FILENAME} is resolving correctly, and if the users are accurately requesting existing paths, this probably won't be a problem, but you might consider adding NS to directives that shouldn't be expanded in subrequests.
ctgraham
 
Posts: 240
Joined: Thu Apr 03, 2014 5:29 am
Location: Pitt ULS


Return to OJS Technical Support

Who is online

Users browsing this forum: Google [Bot] and 2 guests