OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



The artcile's PDF preview doesn't load

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

Re: The artcile's PDF preview doesn't load

Postby Garant » Tue May 06, 2014 10:46 am

Hi Alec!
Thank you!
It was the issue!
Solved with you help!
Garant
 
Posts: 238
Joined: Wed May 30, 2012 8:53 am

Re: The artcile's PDF preview doesn't load

Postby Garant » Sat Jul 19, 2014 12:08 pm

Hi Alec!
It seems that we still have this issue.
When I open the random article's pdf - the error message appears as in my first message. But when I refresh the page - everything loads perfectly.
I see this error:
Code: Select all
TypeError: $.browser is undefined   
...rowser.webkit) { // PDFObject does not correctly work with safari's built-in PDF...

Could you tell me is it another error with some kind of modifications (as I compared - the templates shouldn't have big modifications, maybe, except of few additional JS calls which shouldn't cause any problems)
or some plugins causes this issue?
Example here: https://www3.mruni.eu/ojs/business-syst ... /view/1830
Thank you!
Garant
 
Posts: 238
Joined: Wed May 30, 2012 8:53 am

Re: The artcile's PDF preview doesn't load

Postby asmecher » Mon Jul 21, 2014 10:19 am

Hi Garant,

Yes, I think this is due to local modifications. Off the top of my head, you should be using $.ready() to cause JS to execute once JQuery etc. has been properly loaded, rather than just creating a JS block. The latter is prone to race conditions on the first load, while the browser is still loading/fetching page content.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Re: The artcile's PDF preview doesn't load

Postby Garant » Tue Jul 22, 2014 6:50 am

Hi Alec!
Thank you!
I've removed old unused JS and other one pasted into jQuery ready call.
It seems, that's everything is working now.
But I've noticed that not our OJS nor demo journal hosted on pkp doesn't load articles with IE 8 (x64) browser.
It seems that it doesn't recognize installed Adobe Reader...
Garant
 
Posts: 238
Joined: Wed May 30, 2012 8:53 am

Previous

Return to OJS Technical Support

Who is online

Users browsing this forum: Bing [Bot] and 2 guests