OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Installation process does not even start

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Installation process does not even start

Postby bartneck » Thu Aug 31, 2006 7:19 pm

Hello,

I followed the steps described in the README and when i call index.php i get this error message:

(mysql): SELECT * FROM journals WHERE path = 'indexphp'

Warning: mysql_query(): supplied argument is not a valid MySQL-Link resource in /homepages/10/d20092181/htdocs/hri/lib/adodb/drivers/adodb-mysql.inc.php on line 488

2002: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)


I have not even entered any information and i did not edit the database section in the config.inc.php file. What am i doing wrong?

Thank you for your help

/c
bartneck
 

Postby asmecher » Sat Sep 02, 2006 12:00 am

Hi Bartneck,

Check that your MySQL server is running -- that message indicates that OJS is having trouble connecting. If you haven't performed the installation yet, ensure also that the Installed option is set to Off in config.inc.php before continuing.

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 8851
Joined: Wed Aug 10, 2005 12:56 pm

problem solved

Postby bartneck » Sat Sep 02, 2006 12:33 am

Thank you for the suggestion. It turned out that i was encountering an issue with Mac OS X. Connecting MySQL to PHP through a socket requires a small adjustment in the system's configuration files as described in this document at Apple. I was not even using their server version, but their recommendations solved my problem:

http://docs.info.apple.com/article.html?artnum=301457
bartneck
 


Return to OJS Technical Support

Who is online

Users browsing this forum: No registered users and 2 guests