OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Failed upgrade 2.4.2 to 2.4.3, Unrecognized DAO Metrics DAO

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Failed upgrade 2.4.2 to 2.4.3, Unrecognized DAO Metrics DAO

Postby MartinKoechy » Thu Mar 27, 2014 6:48 am

Hi - we have tried to upgrade our OJS installation from 2.4.2 to 2.4.3. The process, however, fails just before the end with the message "Unrecognized DAO Metrics DAO!". We also tried the upgrade from the terminal/shell, same result. Any ideas how to fix this?

Martin
MartinKoechy
 
Posts: 6
Joined: Thu Dec 12, 2013 5:49 am

Re: Failed upgrade 2.4.2 to 2.4.3, Unrecognized DAO Metrics

Postby asmecher » Thu Mar 27, 2014 8:30 am

Hi Martin,

How did you upgrade the code -- by patching, or full package download, or something else?

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8563
Joined: Wed Aug 10, 2005 12:56 pm

Re: Failed upgrade 2.4.2 to 2.4.3, Unrecognized DAO Metrics

Postby MartinKoechy » Fri Mar 28, 2014 1:38 am

We patched.
MartinKoechy
 
Posts: 6
Joined: Thu Dec 12, 2013 5:49 am

Re: Failed upgrade 2.4.2 to 2.4.3, Unrecognized DAO Metrics

Postby asmecher » Fri Mar 28, 2014 9:20 am

Hi Martin,

Can you confirm that the patch applied successfully -- there were no .rej files generated as a result?

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8563
Joined: Wed Aug 10, 2005 12:56 pm

Re: Failed upgrade 2.4.2 to 2.4.3, Unrecognized DAO Metrics

Postby MartinKoechy » Mon Apr 07, 2014 2:14 am

Yes, the patch has been applied - see below.

server:~/www/ojs$ wget http://geolite.maxmind.com/download/geo ... ity.dat.gz
--2014-03-27 12:20:04-- http://geolite.maxmind.com/download/geo ... ity.dat.gz
Auflösen des Hostnamen »geolite.maxmind.com«.... 108.168.255.243, 2607:f0d0:3:8::4
Verbindungsaufbau zu geolite.maxmind.com|108.168.255.243|:80... verbunden.
HTTP Anforderung gesendet, warte auf Antwort... 200 OK
Länge: 11057413 (11M) [application/octet-stream]
In »GeoLiteCity.dat.gz« speichern.

100%[======================================>] 11.057.413 4,07M/s in 2,6s

2014-03-27 12:20:07 (4,07 MB/s) - »GeoLiteCity.dat.gz« gespeichert [11057413/11057413]

server:~/www/ojs$ gunzip GeoLiteCity.dat.gz
server:~/www/ojs$ mv GeoLiteCity.dat plugins/generic/usageStats
server:~/www/ojs$ php tools/upgrade.php patch

Code version: 2.4.3.0
Database version: 2.4.2.0
Latest version: 2.4.3.0
Database version is older than code version
Run "tools/upgrade.php upgrade" to update
server:~/www/ojs$
server:~/www/ojs$ tools/upgrade.php upgrade
-shell: tools/upgrade.php: Keine Berechtigung
server:~/www/ojs$ tools/upgrade.php upgrade
-shell: tools/upgrade.php: Keine Berechtigung
server:~/www/ojs$ php tools/upgrade.php upgrade
[pre-install]
[load: upgrade.xml]
[version: 2.4.3.0]
[schema: lib/pkp/xml/schema/signoff.xml]
[data: dbscripts/xml/upgrade/2.4.3_preupdate_usageStatistics.xml (skipped)]
[data: dbscripts/xml/upgrade/2.4.3_preupdate_usageStatistics2.xml (skipped)]
[schema: lib/pkp/xml/schema/common.xml]
[schema: lib/pkp/xml/schema/groups.xml]
[schema: lib/pkp/xml/schema/log.xml]
[schema: lib/pkp/xml/schema/announcements.xml]
[schema: lib/pkp/xml/schema/scheduledTasks.xml]
[schema: lib/pkp/xml/schema/temporaryFiles.xml]
[schema: lib/pkp/xml/schema/metadata.xml]
[schema: lib/pkp/xml/schema/reviews.xml]
[schema: lib/pkp/xml/schema/reviewForms.xml]
[schema: lib/pkp/xml/schema/controlledVocab.xml]
[schema: lib/pkp/xml/schema/submissions.xml]
[schema: lib/pkp/xml/schema/comments.xml]
[schema: lib/pkp/xml/schema/notes.xml]
[schema: lib/pkp/xml/schema/gifts.xml]
[schema: lib/pkp/xml/schema/mutex.xml]
[schema: lib/pkp/xml/schema/tombstone.xml]
[schema: lib/pkp/xml/schema/metrics.xml]
[schema: dbscripts/xml/ojs_schema.xml]
[data: dbscripts/xml/indexes.xml]
[schema: plugins/generic/usageStats/schema.xml]
[data: dbscripts/xml/upgrade/remove_timed_views_bots.xml]
[code: Installer Installer::migrateCounterPluginUsageStatistics]
<h1>Unrecognized DAO MetricsDAO!</h1>ojs2: Unrecognized DAO MetricsDAO!
MartinKoechy
 
Posts: 6
Joined: Thu Dec 12, 2013 5:49 am

Re: Failed upgrade 2.4.2 to 2.4.3, Unrecognized DAO Metrics

Postby asmecher » Mon Apr 07, 2014 8:10 am

Hi Martin,

The output you posted doesn't include the patching process -- it looks like the patch has already been applied, so attempting to apply it again doesn't do anything. In any case, can you confirm that the following line exists in classes/core/Application.inc.php:
Code: Select all
'MetricsDAO' => 'classes.statistics.MetricsDAO',
Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8563
Joined: Wed Aug 10, 2005 12:56 pm

Re: Failed upgrade 2.4.2 to 2.4.3, Unrecognized DAO Metrics

Postby MartinKoechy » Wed Apr 23, 2014 6:59 am

SOLVED

Yes, the entry was missing.

I manually added in the file "Application.inc.php" the entry 'MetricsDAO' => 'classes.statistics.MetricsDAO'
and now it works.

Thanks for the note and the help !!!
MartinKoechy
 
Posts: 6
Joined: Thu Dec 12, 2013 5:49 am

Re: Failed upgrade 2.4.2 to 2.4.3, Unrecognized DAO Metrics

Postby asmecher » Wed Apr 23, 2014 8:51 am

Hi Martin,

Glad to hear it -- but beware that if one line of code was missing, others may be too. That line should be included in the OJS 2.4.3 release and is also included in the 2.4.2 to 2.4.3 patch.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8563
Joined: Wed Aug 10, 2005 12:56 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: No registered users and 2 guests