OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



pdf viewer not working

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

pdf viewer not working

Postby jcehe » Thu Dec 19, 2013 8:10 am

The pdf viewer does not load. You can see the box were the pdf should display but the box contains no text. Clicking download this pdf does work. I have checked several other journal sites and those do not appear to be working either. I've tried to do view the page with IE 10 and Firefox 26. Any ideas?
jcehe
 
Posts: 3
Joined: Mon Sep 17, 2012 6:48 pm

Re: pdf viewer not working

Postby JasonNugent » Fri Dec 20, 2013 7:30 am

Hi jcehe,

Which version of OJS are you using? Have you tried Google Chrome? I'd like to debug this, but I would guess that this may be a relatively local problem. If PDF viewing was broken in OJS in general, there would be a lot more posts about it.

Regards,
Jason
JasonNugent
Site Admin
 
Posts: 895
Joined: Tue Jan 10, 2006 6:20 am

Re: pdf viewer not working

Postby Jirrka » Fri Jan 03, 2014 8:59 am

Hi, I have the same problem. I had updated to 2.4.3.0 version, but probably even after the update the viewer worked and stopped to work several day ago (But I am not sure). It does not work in IE, Mozilla, Chrome.
When I use Firebug in Mozilla, I get following message:

Load denied by X-Frame-Options: https://accounts.google.com/ServiceLogi ... authuser=0 does not permit framing.

I tried to look to other pages, but I had not found any OJS instalation using Google Viewer.

Nice day

Jiri
Jirrka
 
Posts: 15
Joined: Thu Jul 18, 2013 7:02 am
Location: Prague

Re: pdf viewer not working

Postby JasonNugent » Thu Jan 09, 2014 7:49 am

Hi everyone,

This appears to be a problem tied to users who are simultaneously viewing PDFs and are also signed into their Google account. Can those who are having problems try logging out of Google completely and then viewing the PDF in OJS?

There is a header that can be sent, X-Frame-Options, set to actually anything at all, which overrides the default behavior here. I'm not sure if this would need to be done by OJS, or if we need to use something other than Google viewer for PDFs.

Regards,
Jason
JasonNugent
Site Admin
 
Posts: 895
Joined: Tue Jan 10, 2006 6:20 am

Re: pdf viewer not working

Postby Jirrka » Thu Jan 09, 2014 8:31 am

JasonNugent wrote:Hi everyone,

This appears to be a problem tied to users who are simultaneously viewing PDFs and are also signed into their Google account. Can those who are having problems try logging out of Google completely and then viewing the PDF in OJS?
There is a header that can be sent, X-Frame-Options, set to actually anything at all, which overrides the default behavior here. I'm not sure if this would need to be done by OJS, or if we need to use something other than Google viewer for PDFs.

Regards,
Jason


Yes, you are correct Jason - if I log out from Google in the browser, than the google viewer starts to work - tested in Mozilla and Chrome, does not work correctly in my IE, but maybe there is something strange with my IE as I have also some other problems with it and I do not use it normally.
Jirrka
 
Posts: 15
Joined: Thu Jul 18, 2013 7:02 am
Location: Prague


Return to OJS Technical Support

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 3 guests