OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Invalid homepage header title image format or upload failed

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Invalid homepage header title image format or upload failed

Postby nasseer » Fri Dec 06, 2013 9:56 am

I've problem Invalid homepage header title image format or upload failed
Errors occurred processing this form:
Invalid homepage header title image format. Accepted formats are .gif, .jpg, or .png
Note the image in jpg format.
Any help appreciated.
Nasseer
nasseer
 
Posts: 7
Joined: Mon Dec 02, 2013 3:56 pm

Re: Invalid homepage header title image format or upload fai

Postby asmecher » Fri Dec 06, 2013 10:24 am

Hi Nasseer,

Please search the forum and check the FAQ; there are many existing posts about this. If you're still having trouble, summarize what you've tried and post it here.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9050
Joined: Wed Aug 10, 2005 12:56 pm

Re: Invalid homepage header title image format or upload fai

Postby nasseer » Fri Dec 06, 2013 2:01 pm

Hi asmecher,
I try all posts about this problem, The problem is still?
Is there a solution has been tested.


Regards,
Nasseer
nasseer
 
Posts: 7
Joined: Mon Dec 02, 2013 3:56 pm

Re: Invalid homepage header title image format or upload fai

Postby asmecher » Fri Dec 06, 2013 4:29 pm

Hi Nasseer,

What have you tried? Have you determined which of the 3 methods OJS is using to check MIME types?

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9050
Joined: Wed Aug 10, 2005 12:56 pm

Re: Invalid homepage header title image format or upload fai

Postby nasseer » Sun Dec 08, 2013 10:40 am

Hello Alec,
I looked at this link in a previous answer to you.
Code: Select all
http://pkp.sfu.ca/wiki/index.php/PKP_Frequently_Asked_Questions#HTML_Galleys_don.27t_display_properly_.2F_files_I_upload_aren.27t_being_identified_properly.

But how do you solve the problem.?
please, Can you clarify what to do step by step?

Thank you for you help!
Regards,
Nasseer
nasseer
 
Posts: 7
Joined: Mon Dec 02, 2013 3:56 pm

Re: Invalid homepage header title image format or upload fai

Postby asmecher » Mon Dec 09, 2013 12:25 pm

Hi Nasseer,

You'll need to determine whether your PHP supports finfo and mime_content_type. Try executing a PHP script containing the following contents:
Code: Select all
<?php
echo function_exists('mime_content_type')?"Yes\n":"No\n";
?>
As for finfo, check your phpinfo() output and look for "fileinfo support".

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9050
Joined: Wed Aug 10, 2005 12:56 pm

Re: Invalid homepage header title image format or upload fai

Postby nasseer » Tue Dec 10, 2013 3:20 pm

Hi,
Hello Alec,
This answer your questions
PHP supports finfo and mime_content_type :No
Configure Command: '--disable-fileinfo'
SPL:SplFileInfo "enabled"

Regards,
Nasseer
nasseer
 
Posts: 7
Joined: Mon Dec 02, 2013 3:56 pm

Re: Invalid homepage header title image format or upload fai

Postby asmecher » Tue Dec 10, 2013 4:31 pm

Hi Nasseer,

SPLFileInfo is not the same as FileInfo.

The best solution will be to enable FileInfo in your PHP deployment. It may be possible to do this just by loading a module but will depend on your server.

Regards,
Alec Smecher
Publoc Knowledge Project Team
asmecher
 
Posts: 9050
Joined: Wed Aug 10, 2005 12:56 pm

Re: Invalid homepage header title image format or upload fai

Postby nasseer » Wed Dec 11, 2013 10:55 am

Hello Alec,

Now the result becomes :

PHP supports finfo and mime_content_type :Yes
fileinfo support :enabled
version: 1.0.5-dev

the issue still?

Thanks,
nasseer
 
Posts: 7
Joined: Mon Dec 02, 2013 3:56 pm

Re: Invalid homepage header title image format or upload fai

Postby asmecher » Wed Dec 11, 2013 11:52 am

Hi Nasseer,

Have you tried uploading images again? (If you're testing finfo support via command-line PHP but your server is running PHP e.g. using mod_php, you may need to restart your web server for the configuration changes to take effect there.)

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9050
Joined: Wed Aug 10, 2005 12:56 pm

Re: Invalid homepage header title image format or upload fai

Postby nasseer » Wed Dec 11, 2013 1:24 pm

Breaking news!!......Breaking news!!.....Breaking news!!
I Can upload Title image..in Site Settings Administration?
But I can not upload Title image in (Step 5. Customizing the Look) With the same error"Errors occurred processing this form
Invalid homepage header logo image format or upload failed. Accepted formats are .gif, .jpg, or .png."

Thanks,
nasseer
 
Posts: 7
Joined: Mon Dec 02, 2013 3:56 pm

Re: Invalid homepage header title image format or upload fai

Postby asmecher » Wed Dec 11, 2013 2:56 pm

Hi Nasseer,

If you can upload an image in one place but not another, it's very likely to be a file permissions problem. Ensure that you have the right file permissions set on the "public" directory (and all of its contents).

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9050
Joined: Wed Aug 10, 2005 12:56 pm

Re: Invalid homepage header title image format or upload fai

Postby nasseer » Mon Dec 23, 2013 5:32 am

Hello Alec,
I Read all the latest solutions
Come back again with the file permissions problem?
ojs Creates folder with Different Owner (nobody) And can not be modified permissions even in FTP?
Is the problem in the my server or in ojs script?

Thank you,
Nasseer
nasseer
 
Posts: 7
Joined: Mon Dec 02, 2013 3:56 pm

Re: Invalid homepage header title image format or upload fai

Postby asmecher » Mon Dec 23, 2013 10:32 am

Hi Nasseer,

This is due to the configuration of your server's SAPI; probably your server is using mod_php, which often has this effect.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9050
Joined: Wed Aug 10, 2005 12:56 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: No registered users and 2 guests