OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Install OJS on Windows XP PHP5.1.4+MySql5.0.18+IIS5.0

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Install OJS on Windows XP PHP5.1.4+MySql5.0.18+IIS5.0

Postby guchao » Wed Jul 05, 2006 4:08 am

I saw serval topics about installing OJS on windows , they did't install OJS successfully.

I have installed OJS on my workstation successfully today.

So I want to share my methods with all of you.
guchao
 
Posts: 5
Joined: Tue Jul 04, 2006 9:54 pm

Postby guchao » Wed Jul 05, 2006 4:20 am

Step 1-

download php-5.1.4-Win32.zip from http://www.php.net
unzip into C:\PHP.

download mysql-5.0.18-win32.zip from http://www.mysql.com
install it.

download ojs-2.1.0-1.tar.gz from this OJS site
unzip into any folder.(eg. D:\Web\OJS)

Step 2-

copy C:\php\php.ini-dist C:\Windows\php.ini

use a text editor open php.ini and modify like this:

a. extension_dir = "C:\PHP\ext"

b. cgi.force_redirect = 0

c. extension=php_mysql.dll

d. in [MySql] section make these changes:
mysql.default_port = 3306
mysql.default_host = localhost
mysql.default_user = youruser
mysql.default_password = yourpassword
guchao
 
Posts: 5
Joined: Tue Jul 04, 2006 9:54 pm

Postby guchao » Wed Jul 05, 2006 4:26 am

Step 3-

Config IIS. Open IIS Manager , add a
.php---c:\php\php-cgi.exe---whole action

Step 4-

you can open your web browse , type url "http://localhost/OJS".

Now , fill the installing form and click "INSTALL" button . You wouldn't get the "blank page".
guchao
 
Posts: 5
Joined: Tue Jul 04, 2006 9:54 pm

Postby yaliang » Tue Jul 11, 2006 2:39 am

Dear Guchao:

I follow your instruction to install OJS (with PHP5.1.4 and MySQL, on IIS 6 and Window Server 2003), however, I got error message -- "HTTP Error 401.1 - Unauthorized: Access is denied due to invalid credentials. Internet Information Services (IIS)".

Since I couldn't verify the installation of PHP with the <?php.info()>, I am trying to modify the access control setting with IIS manager. Do you or other friends have any suggesstion to solve this problem?

Thank you very much :lol:
yaliang
 
Posts: 82
Joined: Tue Jul 11, 2006 1:11 am

Postby asmecher » Tue Jul 11, 2006 9:29 am

Hi yaliang,

There's a typo in your phpinfo script -- the contents of the test script should be:
Code: Select all
<? phpinfo(); ?>
Get this script working first before you move on to installing OJS; this is the easiest way to verify that your PHP installation is working. The PHP installation documentation is fairly good. See the various guides under http://www.php.net/manual/en/install.windows.php.

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 8910
Joined: Wed Aug 10, 2005 12:56 pm

Postby yaliang » Tue Jul 11, 2006 4:24 pm

Dear Asmecher:

Thanks for your information.
Now, the PHP was sucessfully installed and verified. The MySQL was also ready. However, when I url to localhost/ojs/, the error message "You are not authorized to view this page" was shown. Is it a problem of the setting in IIS Manager? Could you give me any suggestion or relative information to solve this problem?
Thanks for your kindly help. :wink:

Best Regards,

Yaliang
yaliang
 
Posts: 82
Joined: Tue Jul 11, 2006 1:11 am

Postby asmecher » Tue Jul 11, 2006 5:03 pm

Hi yaliang,

It's possible that you haven't configured IIS to search for index.php as a default script. Try browsing to http://localhost/ojs/index.php and see if that works; also check that the Internet Guest Account has sufficient priveleges by following these steps:
  • Find the ojs directory in Explorer
  • Right-click and go to Properties
  • Go to the Security tab
  • Ensure that "Internet Guest Account" has "Read & Execute" priveleges. (You may need to set these recursively using the "Replace permission entities on all child objects ..." checkbox under Advanced.)
Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 8910
Joined: Wed Aug 10, 2005 12:56 pm

Postby yaliang » Tue Jul 11, 2006 7:13 pm

Thanks again.
A few minutes ago, I recreated the website with the IIS manager and the problem was magically solved.

Now, I'm going to move the OJS system from the old sever to this new one. Since I'm new to the PHP and MySQL, could you give me more clear instructions about how to backup/import the OJS database with DBMS?
Thanks for your effor and time.

Best Wishes,

Yaliang
yaliang
 
Posts: 82
Joined: Tue Jul 11, 2006 1:11 am

Postby asmecher » Tue Jul 11, 2006 9:00 pm

Hi Yaliang,

To back up your MySQL database to a file, run on the command line:
Code: Select all
mysqldump -u my_mysql_username_here -p my_mysql_database_name_here > output.sql
You will be prompted for the database password. (All the above pieces of information are in OJS's config.inc.php file if you don't know them.) When the password has been entered, the dump tool will create a file called output.sql in the current directory. Move that file onto your new server. Assuming you've created a dabase on the new server with the same name and granted access with the same credentials, run:
Code: Select all
mysql -u my_mysql_username_here -p my_mysql_database_name_here < output.sql
Once again, you'll be prompted for the password. When you've entered this, the database from the dump file (output.sql) will be loaded into the new database.

Once you've copied your OJS installation onto the new server (or unpacked a fresh installation), you'll need to double-check the settings in config.inc.php to make sure they're still accurate (e.g. base URL and database credentials), and run through the Journal Setup pages to make sure that any URLs are updated there.

Hopefully that helps -- let me know if you have any more questions.

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 8910
Joined: Wed Aug 10, 2005 12:56 pm

Postby yaliang » Thu Jul 13, 2006 5:37 am

Thanks for your kindly help. I have copied the whole ojs folder and imported the existed database to the new server. I also modified the config.inc.php file as you mentioned. However, when I connected the localhost/ojs/, I only saw a blank page and the url was not changed (it was localhost/ojs/, not the following one it should be: localhost/ojs/index.php/...).

I try to delete the database and reinstall the OJS with the initial downloaded package. But there's no problem when I connected to localhost/ojs/. Then, I copied the config.inc.php file to the previous folder and try the connection; however, the problem of the blank page was still existed.

I wonder is there anything else I should modify except the config.inc.php file when I want to move the OJS to another server.
yaliang
 
Posts: 82
Joined: Tue Jul 11, 2006 1:11 am

Postby asmecher » Thu Jul 13, 2006 12:14 pm

Hello Yaliang,

Does your new server have the PHP MySQL module installed? See docs/FAQ:
7) The installation form loads successfully, but after clicking the button
to install, a blank page appears and the database was not created.

A: This may indicate that your server does not have the selected PHP database
module installed and enabled (this can be verified by looking at the output
of phpinfo() to see if the required database support exists -- see
http://php.net/phpinfo).

The OJS installer lists database drivers for which the required PHP
extension does not appear to be loaded in brackets (e.g., "[MySQL]").

Most Linux distributions offer a separate package that can be installed for
each supported PHP database module -- e.g., php4-mysql or php-mysql (for
MySQL support), or php4-pgsql or php-pgsql (for PostgreSQL support).

Note also that even with the module installed it may be necessary to modify
your php.ini configuration to load the module, by adding "extension=mysql.so"
or "extension=pgsql.so", for example.

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 8910
Joined: Wed Aug 10, 2005 12:56 pm

Postby yaliang » Thu Jul 13, 2006 6:26 pm

Dear Alec:

Since I can access and log into the reinstalled ojs, I think there isn't any problem with the PHP and MySQL. If you're available to test the websites, please click the following hyperlinks:
1. The reinstalled ojs (available to access):
http://140.118.10.110/ojs-ok/
2. The ojs base copied from the existed server (error of a blank page):
http://140.118.10.110/ojs/

One ther other hand, the layout of the existed website was customized for our purpose. The job was mainly done by modifying the files in the template and style folder. However, when I replace the initial installed files with the edited ones (by coping the template and style files form the existed server to the reinstalled one), the webpages were not displayed correctly. Please compare the following two websites to figure out what I mean:
1. Existed server (with customized layout):
http://140.118.10.104/ojs/index.php/IJDesign
2. The reinstalled ojs with replaced template and style files:
http://140.118.10.110/ojs-ok/index.php/IJDesign

Since the two websites are hosted with different engine (Apache for existed website, and IIS for the new one), is it the reason of the display error? Thank you for your kindly help and time.

Best wishes,

Yaliang
yaliang
 
Posts: 82
Joined: Tue Jul 11, 2006 1:11 am

Postby asmecher » Fri Jul 14, 2006 1:08 am

Hi Yaliang,

Try deleting your template compile cache -- that is, erase all files in cache/t_compile and make sure that the directory is writable by the web server.

Regards,
Alec Smecher
Open Journal Systems Team
asmecher
 
Posts: 8910
Joined: Wed Aug 10, 2005 12:56 pm

Postby yaliang » Fri Jul 14, 2006 3:05 am

Dear Alec:

Thanks for your good suggestion. The problem of incorrect layout was solved by setting the permission in the properties/security setting for the folders. Unfortunately, this solution was not able to solve the first problem which the ojs base was copied from existed server. Anyway, I have got what I need. Thank you very much :P

Best regards,

Yaliang
yaliang
 
Posts: 82
Joined: Tue Jul 11, 2006 1:11 am


Return to OJS Technical Support

Who is online

Users browsing this forum: Bing [Bot] and 9 guests