OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Database connection error during install

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

Database connection error during install

Postby connercbrown » Fri Oct 11, 2013 10:08 am

He everyone.

I've installed OJS on a test system before and had no problems. Now I am installing in on the production server and am running into some issues.

I am installing on a hosted 1and1.com Linux account. When I run the installation, I get the following error:

Errors occurred during installation:

A database error has occurred: Access denied for user 'dbo493766179'@'%' to database 'dbo493766179'

It looks like the system is appending @'%' to the end of the username. Not sure what's going on here. Does anyone have any idea what may be going on here?

Thanks
connercbrown
 
Posts: 2
Joined: Fri Oct 11, 2013 10:02 am

Re: Database connection error during install

Postby asmecher » Fri Oct 11, 2013 11:18 am

Hi connercbrown,

In the message...
Code: Select all
A database error has occurred: Access denied for user 'dbo493766179'@'%' to database 'dbo493766179'
...the "dbo493766179" is the username, the "dbo493766179" is the database name, and the "%" is the hostname. (Note the quotes and the @ syntax to separate username and hostname.) Check your database credentials and try again.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Re: Database connection error during install

Postby connercbrown » Fri Oct 11, 2013 11:38 am

I know the username and password are correct. I was a bit puzzled as to why it is reporting the hostname as % and not the one I typed in.

Any ideas?
connercbrown
 
Posts: 2
Joined: Fri Oct 11, 2013 10:02 am

Re: Database connection error during install

Postby asmecher » Sat Oct 12, 2013 8:40 am

Hi Conner,

Unfortunately no. You could check in the depths of the ADODB library what credentials are being supplied in the actual mysqli_real_connect call; see (OTOH) lib/pkp/lib/adodb/drivers/adodb-mysqli.inc.php, in the _connect function.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm


Return to OJS Technical Support

Who is online

Users browsing this forum: No registered users and 1 guest

cron