OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Problems in uploading images

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

Problems in uploading images

Postby ekiekow » Tue Sep 03, 2013 11:37 am

Hi, I have a problem, everytime I try to upload an image, occurs three problems:

1 -) Sometimes this message appears:
"Invalid image format for the title in the header of the homepage. Acceptable formats are. Gif,. Jpg or. Png. Verify settings mime_type, permission and owner of folder and file size allowed."

2 -) Other times appears:
"manager.setup.journalThumbnailInvalid # # # #"

3 -) When I put a cover on the cover of an issue does not appear even though enabled to appear on the cover editions.

What would be the problem?
ekiekow
 
Posts: 2
Joined: Tue Sep 03, 2013 11:27 am

Re: Problems in uploading images

Postby asmecher » Tue Sep 03, 2013 11:44 am

Hi ekiekow,

Please search the forum; there are lots of threads about MIME type detection. You'll have to find out what strategy your server supports and whether it's properly configured.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8316
Joined: Wed Aug 10, 2005 12:56 pm

Re: Problems in uploading images

Postby ekiekow » Tue Sep 03, 2013 11:57 am

I try it now...
ekiekow
 
Posts: 2
Joined: Tue Sep 03, 2013 11:27 am

Re: Problems in uploading images

Postby akkurtb » Thu Feb 27, 2014 12:17 am

Hello,
There are several problems with my journal site, http://www.ejtcs.org:
1) I am using OJS 3.0 Alpha 1, and I cannot upload any image document (the image file is a JPG with 880 KB) at Management -> Website Settings -> Appearance, and add image button does not work. Dragging the file will upload it, but the system shows that no image file was uploaded.The error was: "No file uploaded or invalid file type". I could see the progress of upload, but eventually it is not very helpful nor successful.
2) Is it about the beta version of the software? Our webmaster decided to install this version, which looks great, and I would love to provide additional data to make it operational. Our journal has not started yet.
Thank you.
Barbaros
akkurtb
 
Posts: 8
Joined: Wed Jan 29, 2014 12:00 am
Location: Istanbul, Turkey

Re: Problems in uploading images

Postby JasonNugent » Thu Feb 27, 2014 4:38 am

Hi Barbaros,

OJS 3.0 Alpha 1 is very new and was a community release designed to show OJS users what the next version of OJS was going to look like. It probably has bugs in it, and my recommendation would be to not use it for a production journal just yet. The first full release of OJS will probably happen this spring.

However, there are a few reasons why images might not upload. You may want to ask your server administrator to look in the system logs for an error message. It could be related to directory permissions, or file sizes, or a general PHP problem. Or, you found a bug in OJS.

Regards,
Jason
JasonNugent
Site Admin
 
Posts: 848
Joined: Tue Jan 10, 2006 6:20 am


Return to OJS Technical Support

Who is online

Users browsing this forum: Google [Bot] and 4 guests