OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



IE-only 404 errors?

Are you responsible for making OJS work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, btbell, michael, bdgregg, barbarah, asmecher

Forum rules
What to do if you have a technical problem with OJS:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OJS Editorial Support and Discussion subforum; if you have a development question, try the OJS Development subforum.

IE-only 404 errors?

Postby sillyKris » Fri Oct 05, 2012 11:38 am

Hi all,

I've been making modifications to our OJS installation at http://smithsonianrex.si.edu and I've encountered a strange problem-- whenever I try to access a 'secondary' page (such as http://smithsonianrex.si.edu/index.php/index/about), the page will display for a moment and then suddenly switch to a '404-- Not Found' error.

This happened shortly after adding the following code to my header.tpl
Code: Select all
<!-- 2012-9-25 KJ added the following 5 lines because IE is a terrible, terrible affliction on the internet landscape -->
<!-- paulirish.com/2008/conditional-stylesheets-vs-css-hacks-answer-neither/ -->
<!--[if lt IE 7]> <html class="ie lt-ie9 lt-ie8 lt-ie7"> <![endif]-->
<!--[if IE 7]>    <html class="ie lt-ie9 lt-ie8"> <![endif]-->
<!--[if IE 8]>    <html class="ie lt-ie9"> <![endif]-->
<!--[if gt IE 8]> <html class="ie"> <![endif]-->


Does anyone have any idea why these conditional statements would cause this behavior, and only on certain pages?

Thanks so much for any help or advice!
sillyKris
 
Posts: 14
Joined: Wed May 09, 2012 10:00 am

Re: IE-only 404 errors?

Postby JasonNugent » Sun Oct 07, 2012 4:57 pm

Hi Kris,

You may want to you look in your Apache error log for 404 errors, which would indicate what item IE is trying to load. It's been a while since I've looked at IE, but I seem to recall that it occasionally tries to fetch some little .ico file or other graphic, and if it's not there then you see a redirection to an error page. It might also be worth comparing the requests with and without your modifications to see what else is trying to load.

Best,
Jason
JasonNugent
Site Admin
 
Posts: 885
Joined: Tue Jan 10, 2006 6:20 am

Re: IE-only 404 errors?

Postby sillyKris » Thu Oct 18, 2012 8:24 am

Hi Jason,

Thanks for your hint-- after some judicious googling I actually found a solution unrelated to PKP. I had referenced a .htc file in my IE-related CSS stylesheets, and that was what was causing the hiccup. I'm still confused as to why it only affected certain pages, but removing the .htc file reference solved the problem.
sillyKris
 
Posts: 14
Joined: Wed May 09, 2012 10:00 am


Return to OJS Technical Support

Who is online

Users browsing this forum: Bing [Bot] and 4 guests