OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



installation problem - install page does not load

Are you responsible for making OMP work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, asmecher

Forum rules
What to do if you have a technical problem with OMP:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OMP Discussion subforum; if you have a development question, try the OMP Development subforum.

installation problem - install page does not load

Postby quacklin » Mon Apr 15, 2013 2:23 pm

Hi,

I have tried to install OMP on a shared server but no luck, the index page keeps loading and redirect to itself:

http://www.terrauomo.com/omp/index.php/index/install

I have tried to insert
Code: Select all
ini_set('display_errors', E_ALL);
on index.php but no error messages.

PHP: Versione 5.3.3-7+squeeze3

Any ideas how to solve?

thank you!

ruben
quacklin
 
Posts: 3
Joined: Mon Apr 15, 2013 2:16 pm

Re: installation problem - install page does not load

Postby asmecher » Mon Apr 15, 2013 2:44 pm

Hi Ruben,

Your web server and PHP installation probably aren't configured to handle URLs that use path_info, i.e. the part of the URL after the "index.php". Figure out whether your web server configuration (e.g. Apache) can be tweaked to support path_info, and if not, try turning on disable_path_info in your config.inc.php file (though this will make URLs much uglier and hasn't been widely tested in OMP).

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8597
Joined: Wed Aug 10, 2005 12:56 pm

Re: installation problem - install page does not load

Postby quacklin » Tue Apr 16, 2013 12:08 am

thanks for your help!

I tried enabling
Code: Select all
;cgi.fix_pathinfo=1
in php.ini config file but no luck

so I disabled

Code: Select all
disable_path_info = On


and installed OK, but looks like the iste is unable to open menus and keep "loading"

http://www.terrauomo.com/omp/index.php? ... page=login

I am on a shared server so there is little config I can make, but possibly is there a .htaccess rule to set pathinfo as it should be on Apache level?

Thanks again!

ruben
quacklin
 
Posts: 3
Joined: Mon Apr 15, 2013 2:16 pm

Re: installation problem - install page does not load

Postby asmecher » Tue Apr 16, 2013 8:24 am

Hi Ruben,

Every server is a little different so I can't say whether e.g. .htaccess overrides might be possible. However, here are some instructions that might help in figuring out how your server is currently configured: http://stackoverflow.com/questions/8706817/check-in-php-if-path-info-is-enabled-on-your-server

I suspect the path_info_disabled mode in OMP may not currently be working and I don't recommend its use.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8597
Joined: Wed Aug 10, 2005 12:56 pm

Re: installation problem - install page does not load

Postby quacklin » Wed Apr 17, 2013 12:11 am

thanks for your reply,

I escalated to my provider and they solved similar cases for moodle cms by inserting this line in the config files:

Code: Select all
$_SERVER['PATH_INFO'] = (empty($_SERVER['PATH_INFO']) ?
$_SERVER['ORIG_PATH_INFO']: $_SERVER['PATH_INFO'] );


It is a bit too technical for me to understand where to put this, I tried to put in config.inc.php and index.php but did not work.

Any idea?

thanks!

ruben
quacklin
 
Posts: 3
Joined: Mon Apr 15, 2013 2:16 pm

Re: installation problem - install page does not load

Postby asmecher » Wed Apr 17, 2013 10:06 am

Hi Ruben,

I can't be sure remotely, but if your server is configured as I'm guessing, that line it should work as the second line (right after the "<?php") in the main index.php file. Turn off the disable_path_info option in config.inc.php, reload the page, and see if that changes anything.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8597
Joined: Wed Aug 10, 2005 12:56 pm


Return to OMP Technical Support

Who is online

Users browsing this forum: No registered users and 1 guest