OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Change language and Login

Are you responsible for making OMP work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, asmecher

Forum rules
What to do if you have a technical problem with OMP:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OMP Discussion subforum; if you have a development question, try the OMP Development subforum.

Change language and Login

Postby vlilloh » Tue Oct 02, 2012 1:14 am

Hi,

Many times, changing the language or the login does not work the first time. I have to try many times until finally works. What could be because of this?

Cheers.
vlilloh
 
Posts: 285
Joined: Thu Feb 07, 2008 3:35 am
Location: Murcia, Spain

Re: Change language and Login

Postby vlilloh » Thu Nov 22, 2012 1:01 am

Hi,

Could be for some settings on my hosting or config.inc.php? All recommended patches applied. With OJS and OCS didn't happen, and the host is the same. It happens with any browser. Above all, it's a little frustrating trying to login repeatedly endlessly for 5 or 10 minutes :)

Cheers.
vlilloh
 
Posts: 285
Joined: Thu Feb 07, 2008 3:35 am
Location: Murcia, Spain

Re: Change language and Login

Postby asmecher » Thu Nov 22, 2012 9:33 am

Hi Vicente,

Do you have session_check_ip turned on in config.inc.php? Try turning it off.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9098
Joined: Wed Aug 10, 2005 12:56 pm

Re: Change language and Login

Postby vlilloh » Thu Nov 22, 2012 11:04 am

Hi Alec,

Nop, I had and have session_check_ip = Off.

Cheers.
vlilloh
 
Posts: 285
Joined: Thu Feb 07, 2008 3:35 am
Location: Murcia, Spain

Re: Change language and Login

Postby asmecher » Thu Nov 22, 2012 11:34 am

Hi Vicente,

Hmm, that's strange. All applications use the same session code, so I'm not sure why OMP would behave differently. Could you try our OMP test drive to see if it happens there too? Have you been able to test from a different machine?

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9098
Joined: Wed Aug 10, 2005 12:56 pm

Re: Change language and Login

Postby vlilloh » Fri Nov 23, 2012 4:10 am

Hi Alec

You are right.

http://omp.sfu.ca/testdrive/index.php/rehabilitation & http://libros.um.es/editum
PC - Windows XP - All browsers
Works fine

http://omp.sfu.ca/testdrive/index.php/rehabilitation
Mac - OS X Mountain Lion - All browsers
Works fine

http://libros.um.es/editum
Mac - OS X Mountain Lion - All browsers
Doesn't work fine.

To the issues of login and language, I add also the issue of page load speed (slowly), doesn't work fine in the last machine & web either.

Cheers.
vlilloh
 
Posts: 285
Joined: Thu Feb 07, 2008 3:35 am
Location: Murcia, Spain

Re: Change language and Login

Postby asmecher » Fri Nov 23, 2012 10:11 am

Hi Vicente,

What platform are you using for your server? Can you double-check that your cache files (cache/*.php) are being created and maintained properly? It might be that low performance causes some kind of race condition, i.e. parts of the page being loaded in a different order, which makes it seem as though the login is failing.

For your own server (libros.um.es), do systems other than MacOS have trouble as well? If so, i.e. if my Linux machine is likely to experience the problem, I might test it from here to see if I can figure out what's happening.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 9098
Joined: Wed Aug 10, 2005 12:56 pm

Re: Change language and Login

Postby vlilloh » Fri Dec 07, 2012 2:00 am

Hi Alec,

Thank you.

How can I double-check my cache files? How can I know if they are being created and maintained properly?

    Only MacOS with any browser have trouble with libros.um.es.
    MacOS with any browser works fine with http://omp.sfu.ca/testdrive
    Windows XP with any browser works fine in any OMP installation.
    I can't test Linux.
The platform in my server is: Linux - Ubuntu Lucid, PHP 5.3.2

I just sent my credentials to James.

Cheers.
vlilloh
 
Posts: 285
Joined: Thu Feb 07, 2008 3:35 am
Location: Murcia, Spain

Re: Change language and Login

Postby jmacgreg » Tue Dec 18, 2012 5:15 pm

Hi Alec, Vicente,

Vicente -- apologies for the delay in getting back to you. I can replicate this problem in OSX, Mountain Lion: I could log in once with the credentials you provided, but after logging out I can't log back in -- the page initially redirects to the dashboard, and then re-redirects to the login page. Similarly, after using the language picker to change to English, trying to choose another locale doesn't work -- the page just refreshes with English still chosen.

I'm not sure what you can do to check the cache files, but Alec may have some further suggestions. I'll be checking on a few other platforms momentarily.

Cheers,
James
jmacgreg
 
Posts: 4190
Joined: Tue Feb 14, 2006 10:50 am

Re: Change language and Login

Postby jmacgreg » Tue Dec 18, 2012 5:35 pm

Hi Alec, Vicente,

One quick update. I just tried logging in and/or changing locales in the following different environments:

OS X Mountain Lion (current machine reported about above): Firefox, Safari
Windows 7 (via VMWare): IE 9, Firefox
Mac OS X Lion (separate machine): Firefox, Safari

... and I ran into inconsistent but persistent problems on all platforms, with all browsers. Generally speaking I could log in the first time I loaded up the browser, but ran into problems after that -- although there were certain cases where I couldn't even log in then. I haven't been able to switch languages at all. Hope that provides a bit more troubleshooting info.

Cheers,
James
jmacgreg
 
Posts: 4190
Joined: Tue Feb 14, 2006 10:50 am


Return to OMP Technical Support

Who is online

Users browsing this forum: No registered users and 1 guest