OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Debug

Are you responsible for making OMP work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, asmecher

Forum rules
What to do if you have a technical problem with OMP:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OMP Discussion subforum; if you have a development question, try the OMP Development subforum.

Debug

Postby vlilloh » Mon Jul 28, 2014 3:21 am

Hi,

I can not get my OMP installation throw any message with the debug options enabled:

Code: Select all
show_stacktrace = On
display_errors = On
deprecation_warnings = On

Currently, the options remain enabled if you can detect the issue.

I appreciate if you can help me. I'm still trying to solve this issue with Jason Nugent.

Thanks,
Vicente
vlilloh
 
Posts: 285
Joined: Thu Feb 07, 2008 3:35 am
Location: Murcia, Spain

Re: Debug

Postby JasonNugent » Mon Jul 28, 2014 5:53 am

Vicente,

It has been a while, but if my memory serves me, we determined that your Apache installation is not on the same server as your OMP document root. Did you sort that out? You may need to change an error_reporting setting in your php.ini file in order to get anything logged correctly.

Regards,
Jason
JasonNugent
Site Admin
 
Posts: 895
Joined: Tue Jan 10, 2006 6:20 am

Re: Debug

Postby vlilloh » Tue Jul 29, 2014 4:08 am

Hi Jason,

Yes, you are right, but Apache installation is in the same server, and before answer to you, I was testing with my system administrator via debug options what errors appear to upload a cover. But I can not get my OMP installation throw any message with the debug options nowhere! There is another issue that I had not yet discovered. Before, I wanted to solve that too.

Currently, error_reporting = E_COMPILE_ERROR|E_RECOVERABLE_ERROR|E_ERROR|E_CORE_ERROR

Thanks,
Vicente
vlilloh
 
Posts: 285
Joined: Thu Feb 07, 2008 3:35 am
Location: Murcia, Spain

Re: Debug

Postby vlilloh » Mon Sep 08, 2014 1:03 am

Hi!

Please, could you help me to solve this issue? It's a little strange, because it works fine with OJS installation, but not with OMP installation, and both installations are on the same server.

It urges us to resolve this issue to solve this issue.

Thanks.
vlilloh
 
Posts: 285
Joined: Thu Feb 07, 2008 3:35 am
Location: Murcia, Spain

Re: Debug

Postby JasonNugent » Mon Sep 08, 2014 4:01 am

Hi Vicente,

I guess I have questions for you:

1. Do you know exactly where your Apache logs are? If so, are there any general PHP messages in the error_log?

2. Are you sure you are editing the correct php.ini file? What happens when you create a PHP file with <?php phpinfo(); ?> in it? What ini file does it tell you that it is loading? Are you logging PHP errors to a different file besides the Apache error log?

Months ago when you gave me server access for a brief period, I could not find any trace of Apache logs on your server.

Regards,
Jason
JasonNugent
Site Admin
 
Posts: 895
Joined: Tue Jan 10, 2006 6:20 am

Re: Debug

Postby vlilloh » Mon Sep 15, 2014 12:38 am

Hi Jason,

The server admin tells me he has thrown all possible php errors when trying to upload a cover. I send you the log by email. It's more complete than the one I sent you earlier. I hope it can be helpful. I can not do anything at server level :(

¿Xdebug could be helpful for you? Please, note you still have server and web access.

Really, thank you very much.
Regards.
vlilloh
 
Posts: 285
Joined: Thu Feb 07, 2008 3:35 am
Location: Murcia, Spain

Re: Debug

Postby JasonNugent » Mon Sep 15, 2014 5:52 am

Hi Vicente,

The first problem I see is this:

finfo_open(): Failed to load magic database at ''

It sounds like you have your magic database config option pointed at an empty string, instead of just commenting out the line in config.inc.php?

You want to make sure that the line begins with a semi colon. That way PHP will use the internal PHP one.

Regards,
Jason
JasonNugent
Site Admin
 
Posts: 895
Joined: Tue Jan 10, 2006 6:20 am

Re: Debug

Postby JasonNugent » Mon Sep 15, 2014 5:53 am

Also:

Message: WARNING: shell_exec() has been disabled for security reasons

You're going to want that turned on. OMP (and OJS) do occasionally use shell commands in order to run external tools, like tar when installing plugins, for example. That's a php.ini setting, not an OMP one.

Regards,
Jason
JasonNugent
Site Admin
 
Posts: 895
Joined: Tue Jan 10, 2006 6:20 am

Re: Debug

Postby vlilloh » Thu Sep 18, 2014 3:53 am

Thanks Jason,

Indeed, the university servers don't allow the execution of these commands "exec" for security reasons.

Is absolutely necessary this commands for the upload of the covers? Would it be possible to do it otherwise? With the upload of the other files I would not have this issue. Otherwise, we could not continue with OMP in our university :(

Cheers,
Vicente
vlilloh
 
Posts: 285
Joined: Thu Feb 07, 2008 3:35 am
Location: Murcia, Spain

Re: Debug

Postby vlilloh » Fri Sep 19, 2014 4:33 am

Hi,

Finally, issue resolved. Just commenting out the the magic database config option and settting another url.

Thank you very much!
Cheers.
vlilloh
 
Posts: 285
Joined: Thu Feb 07, 2008 3:35 am
Location: Murcia, Spain

Re: Debug

Postby JasonNugent » Fri Sep 19, 2014 7:55 am

Glad to hear it.

Cheers,
Jason
JasonNugent
Site Admin
 
Posts: 895
Joined: Tue Jan 10, 2006 6:20 am


Return to OMP Technical Support

Who is online

Users browsing this forum: No registered users and 1 guest