OJS OCS OMP OHS

You are viewing the PKP Support Forum | PKP Home Wiki



Problems with Internet Explorer 8.0

Are you responsible for making OMP work -- installing, upgrading, migrating or troubleshooting? Do you think you've found a bug? Post in this forum.

Moderators: jmacgreg, michael, asmecher

Forum rules
What to do if you have a technical problem with OMP:

1. Search the forum. You can do this from the Advanced Search Page or from our Google Custom Search, which will search the entire PKP site. If you are encountering an error, we especially recommend searching the forum for said error.

2. Check the FAQ to see if your question or error has already been resolved.

3. Post a question, but please, only after trying the above two solutions. If it's a workflow or usability question you should probably post to the OMP Discussion subforum; if you have a development question, try the OMP Development subforum.

Problems with Internet Explorer 8.0

Postby gemusehandler » Wed May 29, 2013 1:21 am

We are experiencing display problems in IE8.
Safari, Chrome, Firefox, Opera, Yandex are all fine. IE8 is not.

Please have a look at http://books.bk.tudelft.nl
Initially we thought the problem was with us, because we modified the stylesheet.
However, removing the stylesheet doesn't solve the issue.

The carousel doesn't seem to fit the page and is pushed below the left side bar.
And there is something strange with the fonts.
These problems do not occur in other browsers than Internet Explorer.

I checked the OMP examples listed on the PKP website and they all seem to suffer from the carousel problem under IE8.
At that point we decided to stop looking for an answer and post this topic :wink:

Screen Shot 2013-05-29 at 1.18.04 PM.png
Screen Shot 2013-05-29 at 1.18.04 PM.png (201.15 KiB) Viewed 1735 times
Attachments
Screen Shot 2013-05-29 at 1.18.28 PM.png
Screen Shot 2013-05-29 at 1.18.28 PM.png (285.67 KiB) Viewed 1735 times
gemusehandler
 
Posts: 30
Joined: Sun May 19, 2013 12:30 am

Re: Problems with Internet Explorer 8.0

Postby asmecher » Wed May 29, 2013 8:39 am

Hi gemusehandler,

Unfortunately [sic] I can't run IE over here -- but I wonder if there's compatibility problems between IE8 and the roundabout plugin we're using to display the carousel; that's available here. Do the demo pages there look as they should with IE8?

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8599
Joined: Wed Aug 10, 2005 12:56 pm

Re: Problems with Internet Explorer 8.0

Postby gemusehandler » Wed May 29, 2013 8:55 am

Hi Alec. I just left my workplace and heading home.
Can't test it with a 'real' PC.
With my laptop in the bus I just checked FredHQ using Alkaline.
Seems that FredHQ experiences the very same problem.
Last edited by gemusehandler on Wed Jun 12, 2013 5:50 am, edited 1 time in total.
gemusehandler
 
Posts: 30
Joined: Sun May 19, 2013 12:30 am

Re: Problems with Internet Explorer 8.0

Postby asmecher » Wed May 29, 2013 9:35 am

Hi gemusehandler,

Hmm, that's too bad -- in that case we may have to swap out carousel plugins if we want IE8 support.

I've filed this at http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=8237; feel free to CC yourself on the entry for status changes.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8599
Joined: Wed Aug 10, 2005 12:56 pm

Re: Problems with Internet Explorer 8.0

Postby gemusehandler » Wed Jun 12, 2013 5:53 am

Alec we had another look at the IE8 OMP issue.

From our experience the 1.0b did fine.
Problem occurred around the time we updated to OMP 1.0.0.0
I can not be 100% positive that the update is indeed to blame :?

Previously you and I came to a point where we would point fingers at the carousel.
However, your demo site http://pkp.sfu.ca/omp/presentation/index (OMP 1.0.0.0) is doing fine in IE8!
The problem can't therefor not be the carousel.

Other sites listed at the PKP site do suffer from the same problem that we experience,
http://libros.um.es/editum for instance (also OMP 1.0.0.0).
Could you please have a second look at this pesky issue.

There is definitely something out there that prevents sidebar and carousel to live next to each other.
We would really appreciate a solution.
gemusehandler
 
Posts: 30
Joined: Sun May 19, 2013 12:30 am

Re: Problems with Internet Explorer 8.0

Postby asmecher » Wed Jun 12, 2013 12:04 pm

Hi gemusehandler,

I suspect it's a race condition where two components are loading at the same time, and depending on which finishes first, the width calculation will either succeed or fail. That's just a guess, however -- I can't test with IE8 over here in Linux-land -- but I've asked one of our developers to see if they can duplicate the problem.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8599
Joined: Wed Aug 10, 2005 12:56 pm

Re: Problems with Internet Explorer 8.0

Postby gemusehandler » Fri Jun 21, 2013 5:57 pm

Alec, would that possible 'race' be influenced by the order in which the elements are included in the CSS?
gemusehandler
 
Posts: 30
Joined: Sun May 19, 2013 12:30 am

Re: Problems with Internet Explorer 8.0

Postby asmecher » Fri Jun 21, 2013 11:18 pm

Hi gemusehandler,

That's pretty unlikely -- but stranger things have happened. More likely the order in which AJAX subrequests run, or (related) the order in which DOM elements become available to JavaScript.

Regards,
Alec Smecher
Public Knowledge Project Team
asmecher
 
Posts: 8599
Joined: Wed Aug 10, 2005 12:56 pm


Return to OMP Technical Support

Who is online

Users browsing this forum: No registered users and 1 guest