You are viewing the PKP Support Forum | PKP Home Wiki

error install for harvester2 on FC5

Open Harvester Systems support questions and answers, bug reports, and development issues.

Moderators: jmacgreg, michael, John

Forum rules
The Public Knowledge Project Support Forum is moving to http://forum.pkp.sfu.ca

This forum will be maintained permanently as an archived historical resource, but all new questions should be added to the new forum. Questions will no longer be monitored on this old forum after March 30, 2015.

error install for harvester2 on FC5

Postby kim » Thu Jun 08, 2006 6:09 am


I have downloaded the harvester2.0.0 on my server (FC5) and I would install it with the file /docs/README but I m in error... and when I launch the command line > php /tools/install.php I have this error "erreur de segmentation"

After I have this error too : "
<br />
<b>Warning</b>: First argument to array_keys() should be an array in <b>/portail/h2/classes/install/form/InstallForm.inc.php</b> on line <b>84</b><br />

Locale Settings
Primary Locale
<br />
<b>Warning</b>: Invalid argument supplied for foreach() in <b>/portail/h2/tools/install.php</b> on line <b>228</b><br />
##common.select## (en_US):

somebody help me please !!! :wink:
Posts: 5
Joined: Tue Apr 13, 2004 4:22 am

Postby asmecher » Thu Jun 08, 2006 9:05 am

Hello Kim,

Please ensure you're entering a value for "Additional Locales" such as en_US.

The segmentation fault is a PHP bug; if you're getting it regularly, I'd suggest updating to a more recent version of PHP.

Let us know if you run into any additional problems...

Alec Smecher
Open Journal Systems Team
Posts: 10015
Joined: Wed Aug 10, 2005 12:56 pm

Return to Open Harvester Systems Support and Development

Who is online

Users browsing this forum: No registered users and 1 guest