You are viewing the PKP Support Forum | PKP Home Wiki

problem with harvester 2.3.0 test

Open Harvester Systems support questions and answers, bug reports, and development issues.

Moderators: jmacgreg, michael, John

Forum rules
Developer Resources:

Git: You can access our public Git Repository here. Comprehensive Git usage instructions are available on the wiki.

Bugzilla: You can access our Bugzilla report tracker here.

Search: You can use our Google Custom Search to search across our main website, the support forum, and Bugzilla.

Questions and discussion are welcome.

problem with harvester 2.3.0 test

Postby xmu_chen » Thu Mar 26, 2009 2:23 am

hi Smecher,

I am testing the new version harvester 2.3.0 recently. I have two problems needing your help.
First, when the system harvesting an archinve, it meet an error with "Invalid character". but the old system (2.0.1) can run right. and I used "ListRecord" to show the record at web browser, it shows right. what is the different the new version and the old one? and how can I modify it ? I have tried several archives, it meets the same error,but the v2.0.1 runs right.

Second, how to use ZEND Framework Search Plugin? the following is my processing:
login with admin, and turn to Home > Site Administration > Plugins > Generic Plugins , click "Enable" below "ZEND Framework Search Plugin". then click "Settings ", I left the "Solr URL" blank , and save the form.
after it , I begin harvester metadata from archieve. it had harvestered hundreds of records, although it met errors.
then, I begin to search, but the result is 0. It means that the ZEND Framework Search Plugin dose not work.
Could you tell me how to use the ZEND Framework Search Plugin?

Thank you very much!
Posts: 22
Joined: Tue Oct 30, 2007 6:07 am

Re: problem with harvester 2.3.0 test

Postby asmecher » Thu Mar 26, 2009 7:05 am

Hi xmu_chen,

What is the OAI URL that is causing problems? (If you'd rather not post it publicly, PM me directly.)

As for the ZendSearch implementation, check to see whether the cache/recordsIndex directory exists and is writable by PHP scripts. It should grow in size as content is indexed using the Zend Search plugin.

Alec Smecher
Public Knowledge Project Team
Posts: 9920
Joined: Wed Aug 10, 2005 12:56 pm

Return to Open Harvester Systems Support and Development

Who is online

Users browsing this forum: No registered users and 1 guest